summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-11-14 20:11:20 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-11-14 20:11:20 +0000
commit86d9aa55100e99e412be3acab701f2a30611ccc0 (patch)
tree6b5b35ee07410e04271e6bb4b7cc744e483553b4 /gnustep-libs
parentAdd BSD-1 to MISC-FREE group (diff)
downloadgentoo-2-86d9aa55100e99e412be3acab701f2a30611ccc0.tar.gz
gentoo-2-86d9aa55100e99e412be3acab701f2a30611ccc0.tar.bz2
gentoo-2-86d9aa55100e99e412be3acab701f2a30611ccc0.zip
Maintenance release bump, ebuild cleanup
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/pantomime/ChangeLog9
-rw-r--r--gnustep-libs/pantomime/pantomime-1.2.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/gnustep-libs/pantomime/ChangeLog b/gnustep-libs/pantomime/ChangeLog
index baa88ae496c8..8c74d521351b 100644
--- a/gnustep-libs/pantomime/ChangeLog
+++ b/gnustep-libs/pantomime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnustep-libs/pantomime
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/pantomime/ChangeLog,v 1.24 2010/07/07 20:52:11 voyageur Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/pantomime/ChangeLog,v 1.25 2011/11/14 20:11:20 voyageur Exp $
+
+*pantomime-1.2.0 (14 Nov 2011)
+
+ 14 Nov 2011; Bernard Cafarelli <voyageur@gentoo.org> +pantomime-1.2.0.ebuild:
+ Maintenance release bump, ebuild cleanup
07 Jul 2010; Bernard Cafarelli <voyageur@gentoo.org>
pantomime-1.2.0_pre3-r1.ebuild,
diff --git a/gnustep-libs/pantomime/pantomime-1.2.0.ebuild b/gnustep-libs/pantomime/pantomime-1.2.0.ebuild
new file mode 100644
index 000000000000..6e44ebb8fc55
--- /dev/null
+++ b/gnustep-libs/pantomime/pantomime-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/pantomime/pantomime-1.2.0.ebuild,v 1.1 2011/11/14 20:11:20 voyageur Exp $
+
+EAPI=4
+inherit eutils gnustep-2
+
+MY_P=${P/p/P}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A set of Objective-C classes that model a mail system."
+HOMEPAGE="http://www.collaboration-world.com/pantomime/"
+SRC_URI="http://download.gna.org/gnustep-nonfsf/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 Elm"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
+ Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd "${S}"/Documentation
+ dodoc AUTHORS README TODO
+ docinto rfc
+ dodoc RFC/*
+}