summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit469c774bcd0309358560d5b77f5346fb8804f9bf (patch)
treece4119225d8c992262a6486b5bb41718a6a9529c /kde-base/cantor
parent[profiles] Update kde mask (diff)
downloadgentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.gz
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.tar.bz2
gentoo-2-469c774bcd0309358560d5b77f5346fb8804f9bf.zip
[kde-base] Add KDE SC 4.7.1
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.7.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 86dfd3506fad..64da96615189 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.41 2011/08/15 19:17:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.42 2011/09/07 20:13:42 alexxy Exp $
+
+*cantor-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +cantor-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
15 Aug 2011; Markus Meier <maekke@gentoo.org> cantor-4.6.5.ebuild:
x86 stable, bug #377465
diff --git a/kde-base/cantor/cantor-4.7.1.ebuild b/kde-base/cantor/cantor-4.7.1.ebuild
new file mode 100644
index 000000000000..665abec6c1dd
--- /dev/null
+++ b/kde-base/cantor/cantor-4.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.7.1.ebuild,v 1.1 2011/09/07 20:13:42 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}