summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commitb0cf2ebbfc7626d65b374788654d4e26028bda3f (patch)
tree473933e2eaf30d14938b24846be4b834a0d385d4 /kde-base/dolphin
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadgentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.gz
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.bz2
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.zip
Version bump to KDE 4.0.1.
(Portage version: 2.1.4.1)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog10
-rw-r--r--kde-base/dolphin/dolphin-4.0.1.ebuild39
-rw-r--r--kde-base/dolphin/files/dolphin-4.0.1-linkage.patch21
-rw-r--r--kde-base/dolphin/files/dolphin-4.0.1-make-semantic-desktop-optional.patch35
4 files changed, 104 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 4a409857195b..29cee76188ce 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.2 2008/01/18 00:10:28 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.3 2008/02/07 00:10:54 philantrop Exp $
+
+*dolphin-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/dolphin-4.0.1-linkage.patch,
+ +files/dolphin-4.0.1-make-semantic-desktop-optional.patch,
+ +dolphin-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
18 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org>
+files/dolphin-4.0.0-linkage.patch,
diff --git a/kde-base/dolphin/dolphin-4.0.1.ebuild b/kde-base/dolphin/dolphin-4.0.1.ebuild
new file mode 100644
index 000000000000..8cd6a36da6f0
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.0.1.ebuild,v 1.1 2008/02/07 00:10:54 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND="
+ >=kde-base/libkonq-${PV}:${SLOT}
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+
+# Without this patch, things don't link properly,
+# unless we recompile lib/konq here too.
+PATCHES="${FILESDIR}/${P}-linkage.patch
+${FILESDIR}/${P}-make-semantic-desktop-optional.patch"
+
+pkg_setup() {
+ if use semantic-desktop; then
+ KDE4_BUILT_WITH_USE_CHECK="--missing false kde-base/kdelibs:${SLOT} semantic-desktop"
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_compile
+}
diff --git a/kde-base/dolphin/files/dolphin-4.0.1-linkage.patch b/kde-base/dolphin/files/dolphin-4.0.1-linkage.patch
new file mode 100644
index 000000000000..dabf3e76368d
--- /dev/null
+++ b/kde-base/dolphin/files/dolphin-4.0.1-linkage.patch
@@ -0,0 +1,21 @@
+diff -ur kdebase-3.97.0/apps/dolphin/src/CMakeLists.txt kdebase-3.97.0.patched/apps/dolphin/src/CMakeLists.txt
+--- kdebase-3.97.0/apps/dolphin/src/CMakeLists.txt 2007-11-20 23:01:04.000000000 +0100
++++ kdebase-3.97.0.patched/apps/dolphin/src/CMakeLists.txt 2007-12-10 13:23:37.000000000 +0100
+@@ -59,7 +59,7 @@
+
+ kde4_add_plugin(dolphinpart ${dolphinpart_SRCS})
+
+-target_link_libraries(dolphinpart dolphinprivate)
++target_link_libraries(dolphinpart dolphinprivate ${KDE4_KPARTS_LIBS})
+
+ install(TARGETS dolphinpart DESTINATION ${PLUGIN_INSTALL_DIR} )
+
+@@ -113,7 +113,7 @@
+ dolphinmainwindow.h DolphinMainWindow)
+ kde4_add_executable(dolphin ${dolphin_SRCS})
+
+-target_link_libraries(dolphin ${KDE4_KDEPRINT_LIBS} ${KDE4_KFILE_LIBS} konq dolphinprivate)
++target_link_libraries(dolphin ${KDE4_KDEPRINT_LIBS} ${KDE4_KFILE_LIBS} ${KDE4_KPARTS_LIBS} konq dolphinprivate)
+
+ if (Nepomuk_FOUND)
+ target_link_libraries(dolphin ${NEPOMUK_LIBRARIES})
diff --git a/kde-base/dolphin/files/dolphin-4.0.1-make-semantic-desktop-optional.patch b/kde-base/dolphin/files/dolphin-4.0.1-make-semantic-desktop-optional.patch
new file mode 100644
index 000000000000..d9c1efb26978
--- /dev/null
+++ b/kde-base/dolphin/files/dolphin-4.0.1-make-semantic-desktop-optional.patch
@@ -0,0 +1,35 @@
+commit b5a2927b633d2ad357febe13efc717b02f04a5ba
+Author: Ingmar Vanhassel <ingmar.vanhassel@gmail.com>
+Date: Sat Jan 12 15:28:44 2008 +0100
+
+ Make Nepomuk & Soprano optional dependencies.
+ Move the macro_optional_find_package({nepomuk,soprano}) statements before checking the results.r
+---
+ kdebase/apps/dolphin/src/CMakeLists.txt | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/kdebase/apps/dolphin/src/CMakeLists.txt b/kdebase/apps/dolphin/src/CMakeLists.txt
+index f9902dc..c379e95 100644
+--- a/kdebase/apps/dolphin/src/CMakeLists.txt
++++ b/kdebase/apps/dolphin/src/CMakeLists.txt
+@@ -1,3 +1,8 @@
++macro_optional_find_package(Nepomuk)
++macro_optional_find_package(Soprano)
++macro_bool_to_01(Nepomuk_FOUND HAVE_NEPOMUK)
++
++configure_file(config-nepomuk.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-nepomuk.h )
+
+ add_subdirectory( pics )
+ add_subdirectory( tests )
+@@ -40,11 +45,6 @@ kde4_add_kcfg_files(dolphinprivate_LIB_SRCS
+
+ kde4_add_library(dolphinprivate SHARED ${dolphinprivate_LIB_SRCS})
+
+-find_package(Nepomuk)
+-find_package(Soprano)
+-macro_bool_to_01(Nepomuk_FOUND HAVE_NEPOMUK)
+-
+-configure_file(config-nepomuk.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-nepomuk.h )
+
+ target_link_libraries(dolphinprivate ${KDE4_KFILE_LIBS} konq ${BLITZ_LIBRARIES})
+ if (Nepomuk_FOUND)