summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:18:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:18:25 +0000
commit2232310b520a523e694cda4fb351fa37d805ea09 (patch)
treec243a2254b343d9b7de956929765cedeb67a5c07 /kde-base/kalzium
parentVersion bump KDE 4.4.3 (diff)
downloadgentoo-2-2232310b520a523e694cda4fb351fa37d805ea09.tar.gz
gentoo-2-2232310b520a523e694cda4fb351fa37d805ea09.tar.bz2
gentoo-2-2232310b520a523e694cda4fb351fa37d805ea09.zip
Version bump KDE 4.4.3
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.4.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index ab94301c6d1b..81b137ef9050 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.162 2010/03/31 22:04:05 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.163 2010/05/03 20:18:25 alexxy Exp $
+
+*kalzium-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -kalzium-4.3.4.ebuild,
-kalzium-4.4.0.ebuild:
diff --git a/kde-base/kalzium/kalzium-4.4.3.ebuild b/kde-base/kalzium/kalzium-4.4.3.ebuild
new file mode 100644
index 000000000000..0b5b86dc6724
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.4.3.ebuild,v 1.1 2010/05/03 20:18:25 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +handbook +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-meta_src_configure
+}