summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-04-19 12:25:53 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-04-19 12:25:53 +0000
commitf8552acca162ad1fc85f1fc0dcc841cf5d0bfd70 (patch)
tree6700de6603b2db811014c5ab519622038c820633 /kde-base/kdebase
parentAdding IUSE (Manifest recommit) (diff)
downloadgentoo-2-f8552acca162ad1fc85f1fc0dcc841cf5d0bfd70.tar.gz
gentoo-2-f8552acca162ad1fc85f1fc0dcc841cf5d0bfd70.tar.bz2
gentoo-2-f8552acca162ad1fc85f1fc0dcc841cf5d0bfd70.zip
Version bump
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/ChangeLog5
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.2.21
-rw-r--r--kde-base/kdebase/kdebase-3.2.1.ebuild14
-rw-r--r--kde-base/kdebase/kdebase-3.2.2.ebuild125
4 files changed, 140 insertions, 5 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 6f9b1013032b..f3fb1d642d7f 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.123 2004/04/17 08:28:23 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.124 2004/04/19 12:22:34 caleb Exp $
+
+ 19 Apr 2004; Caleb Tennis <caleb@gentoo.org> :
+ Version bump
17 Apr 2004; Travis Tilley <lv@gentoo.org> kdebase-3.2.1.ebuild:
marked stable on amd64
diff --git a/kde-base/kdebase/files/digest-kdebase-3.2.2 b/kde-base/kdebase/files/digest-kdebase-3.2.2
new file mode 100644
index 000000000000..94af0432e158
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.2.2
@@ -0,0 +1 @@
+MD5 81a348e01625f77beeb53755cb28ba85 kdebase-3.2.2.tar.bz2 17216476
diff --git a/kde-base/kdebase/kdebase-3.2.1.ebuild b/kde-base/kdebase/kdebase-3.2.1.ebuild
index 64892a0f9b02..349443e78406 100644
--- a/kde-base/kdebase/kdebase-3.2.1.ebuild
+++ b/kde-base/kdebase/kdebase-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.2.1.ebuild,v 1.7 2004/04/17 08:28:23 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.2.1.ebuild,v 1.8 2004/04/19 12:22:34 caleb Exp $
inherit kde-dist
@@ -45,9 +45,15 @@ src_compile() {
use pam \
&& myconf="$myconf --with-pam=yes" \
|| myconf="$myconf --with-pam=no --with-shadow"
- use java \
- && myconf="$myconf --with-java=$(java-config --jdk-home)" \
- || myconf="$myconf --without-java"
+ if [[ `use java` ]]; then
+ if [[ `has_version virtual/jdk` ]]; then
+ myconf="$myconf --with-java=$(java-config --jdk-home)"
+ else
+ myconf="$myconf --with-java=$(java-config --jre-home)"
+ fi
+ else
+ myconf="$myconf --without-java"
+ fi
kde_src_compile myconf configure
kde_remove_flag kdm/kfrontend -fomit-frame-pointer
diff --git a/kde-base/kdebase/kdebase-3.2.2.ebuild b/kde-base/kdebase/kdebase-3.2.2.ebuild
new file mode 100644
index 000000000000..87be5ca7088f
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.2.2.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.2.2.ebuild,v 1.1 2004/04/19 12:22:34 caleb Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+IUSE="ldap pam motif encode cups ssl opengl samba java"
+
+DEPEND="media-sound/cdparanoia
+ ldap? ( net-nds/openldap )
+ pam? ( sys-libs/pam )
+ motif? ( x11-libs/openmotif )
+ encode? ( media-sound/lame )
+ cups? ( net-print/cups )
+ ssl? ( dev-libs/openssl )
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )
+ java? ( || ( virtual/jdk virtual/jre ) )
+ >=media-libs/freetype-2"
+RDEPEND="${DEPEND}
+ sys-apps/eject"
+
+src_unpack() {
+ if [ `has sandbox ${FEATURES}` -a ${PORTAGE_TMPDIR} != "/var/tmp" ]; then
+ eerror "Due to a portage bug, kdebase cannot currently emerge properly"
+ eerror "in sandbox mode if your PORTAGE_TMPDIR has been changed."
+ eerror "Please change your PORTAGE_TMPDIR back to /var/tmp or turn"
+ eerror "off the sandbox for this compilation."
+ die
+ fi
+
+ kde_src_unpack
+ cd ${S} && aclocal
+}
+
+src_compile() {
+ myconf="$myconf --with-dpms --with-cdparanoia"
+ myconf="$myconf `use_with ldap` `use_with motif`"
+ myconf="$myconf `use_with encode lame` `use_with cups`"
+ myconf="$myconf `use_with opengl gl` `use_with ssl`"
+
+ use pam \
+ && myconf="$myconf --with-pam=yes" \
+ || myconf="$myconf --with-pam=no --with-shadow"
+
+ if [[ `use java` ]]; then
+ if [[ `has_version virtual/jdk` ]]; then
+ myconf="$myconf --with-java=$(java-config --jdk-home)"
+ else
+ myconf="$myconf --with-java=$(java-config --jre-home)"
+ fi
+ else
+ myconf="$myconf --without-java"
+ fi
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+}
+
+src_install() {
+ kde_src_install
+ cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup" install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kde.pam kde
+ # kde-np is new requirement for 3.2 autologins - #33690
+ newins ${FILESDIR}/kde-np.pam kde-np
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ epatch ${FILESDIR}/${PVR}/startkde-${PVR}-gentoo.diff
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # kcontrol modules
+ cd ${D}/${KDEDIR}/etc/xdg/menus
+ ln -s default_kde-settings.menu kde-settings.menu
+ ln -s default_kde-information.menu kde-information.menu
+ ln -s default_kde-screensavers.menu kde-screensavers.menu
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ dodir ${KDEDIR}/share/config/kdm/sessions
+ sed -e "s:_PREFIX_:${PREFIX}:g" \
+ -e "s:_RANDOM_:${RANDOM}${RANDOM}:g" \
+ ${FILESDIR}/${PVR}/kdmrc > kdmrc
+ sed -e "s:_PREFIX_:${PREFIX}:g" ${FILESDIR}/${PVR}/Xsetup > Xsetup
+
+ cp ${FILESDIR}/${PVR}/backgroundrc .
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ dodir /usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}