summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-28 17:33:47 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-28 17:33:47 +0000
commit26f0ead5e18abc1842a541478f873db60781ea1b (patch)
tree94ea8127de750ceba1d138b075c8ce48e72c2d1f /kde-base/kdebindings-csharp
parenteapi=3 (diff)
downloadgentoo-2-26f0ead5e18abc1842a541478f873db60781ea1b.tar.gz
gentoo-2-26f0ead5e18abc1842a541478f873db60781ea1b.tar.bz2
gentoo-2-26f0ead5e18abc1842a541478f873db60781ea1b.zip
Added revbump and patch for use with mono-2.8; specified correct dependencies for -r0 and -r1 (bug 341497)
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdebindings-csharp')
-rw-r--r--kde-base/kdebindings-csharp/ChangeLog10
-rw-r--r--kde-base/kdebindings-csharp/files/kdebindings-csharp-4.4.5-mono-2.8.patch23
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5-r1.ebuild65
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild6
4 files changed, 100 insertions, 4 deletions
diff --git a/kde-base/kdebindings-csharp/ChangeLog b/kde-base/kdebindings-csharp/ChangeLog
index a4d217df449c..fd505060368b 100644
--- a/kde-base/kdebindings-csharp/ChangeLog
+++ b/kde-base/kdebindings-csharp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kdebindings-csharp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.47 2011/01/26 20:28:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.48 2011/01/28 17:33:47 dilfridge Exp $
+
+*kdebindings-csharp-4.4.5-r1 (28 Jan 2011)
+
+ 28 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ kdebindings-csharp-4.4.5.ebuild, +kdebindings-csharp-4.4.5-r1.ebuild,
+ +files/kdebindings-csharp-4.4.5-mono-2.8.patch:
+ Added revbump and patch for use with mono-2.8; specified correct
+ dependencies for -r0 and -r1 (bug 341497)
*kdebindings-csharp-4.6.0 (26 Jan 2011)
diff --git a/kde-base/kdebindings-csharp/files/kdebindings-csharp-4.4.5-mono-2.8.patch b/kde-base/kdebindings-csharp/files/kdebindings-csharp-4.4.5-mono-2.8.patch
new file mode 100644
index 000000000000..32674c668d41
--- /dev/null
+++ b/kde-base/kdebindings-csharp/files/kdebindings-csharp-4.4.5-mono-2.8.patch
@@ -0,0 +1,23 @@
+diff -uar kdebindings-4.4.5-orig/csharp/kimono/CMakeLists.txt kdebindings-4.4.5/csharp/kimono/CMakeLists.txt
+--- kdebindings-4.4.5-orig/csharp/kimono/CMakeLists.txt 2010-10-24 16:11:27.000000000 +0200
++++ kdebindings-4.4.5/csharp/kimono/CMakeLists.txt 2010-10-24 16:12:17.000000000 +0200
+@@ -22,7 +22,7 @@
+ ${KDE4_KDECORE_LIBS} ${KDE4_KIO_LIBS})
+
+ # write FindPackage modules for these
+-pkg_search_module(MONO mono)
++pkg_search_module(MONO mono-2 mono)
+ pkg_search_module(GLIB2 glib-2.0)
+
+ # if libmono-dev is not installed, then MONO_INCLUDES is not defined and compiling
+diff -uar kdebindings-4.4.5-orig/csharp/kimono/src/kimonopluginfactory.cpp kdebindings-4.4.5/csharp/kimono/src/kimonopluginfactory.cpp
+--- kdebindings-4.4.5-orig/csharp/kimono/src/kimonopluginfactory.cpp 2010-10-24 16:11:27.000000000 +0200
++++ kdebindings-4.4.5/csharp/kimono/src/kimonopluginfactory.cpp 2010-10-24 16:12:40.000000000 +0200
+@@ -44,6 +44,7 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <glib.h>
+
+ class QWidget;
+
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5-r1.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5-r1.ebuild
new file mode 100644
index 000000000000..52accc872b7e
--- /dev/null
+++ b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5-r1.ebuild,v 1.1 2011/01/28 17:33:47 dilfridge Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="csharp"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta mono
+
+DESCRIPTION="C# bindings for KDE and Qt"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="akonadi debug +phonon plasma qimageblitz qscintilla semantic-desktop"
+
+DEPEND="
+ >=dev-lang/mono-2.8
+ $(add_kdebase_dep smoke 'akonadi?,phonon?,qimageblitz?,qscintilla?,semantic-desktop?,webkit?')
+ semantic-desktop? ( >=dev-libs/soprano-2.3.73[clucene] )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="smoke/"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.4.1-make-stuff-optional.patch
+ "${FILESDIR}/${P}"-mono-2.8.patch )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+
+ if use plasma && ! use webkit; then
+ eerror
+ eerror "The plasma USE flag requires the webkit USE flag to be enabled."
+ eerror
+ eerror "Please enable webkit or disable plasma."
+ die "plasma requires webkit"
+ fi
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ # Disable soprano index (clucene) bindings
+ rm -f csharp/soprano/soprano/Soprano_Index_{CLuceneIndex,IndexFilterModel}.cs || die
+ sed -e 's/\${SOPRANO_INDEX_LIBRARIES}//g' \
+ -i csharp/soprano/CMakeLists.txt || die 'failed to remove clucene from link'
+
+ sed -e "/add_subdirectory( examples )/ s:^:#:" \
+ -i csharp/plasma/CMakeLists.txt || die 'failed to disable examples'
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_enable plasma PLASMA_SHARP)
+ $(cmake-utils_use_enable phonon PHONON_SHARP)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SHARP)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_SHARP)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SHARP)
+ )
+ kde4-meta_src_configure
+}
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild
index 315870b79aef..ae544220b014 100644
--- a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild
+++ b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild,v 1.4 2010/08/09 17:34:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.5.ebuild,v 1.5 2011/01/28 17:33:47 dilfridge Exp $
EAPI="3"
@@ -14,7 +14,7 @@ KEYWORDS="amd64 ppc x86"
IUSE="akonadi debug +phonon plasma qimageblitz qscintilla semantic-desktop"
DEPEND="
- dev-lang/mono
+ <dev-lang/mono-2.8
$(add_kdebase_dep smoke 'akonadi?,phonon?,qimageblitz?,qscintilla?,semantic-desktop?,webkit?')
semantic-desktop? ( >=dev-libs/soprano-2.3.73[clucene] )
"