summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-20 18:12:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-20 18:12:51 +0000
commit49edea1b55bae5ec0124a231d4c5090a8fcc437f (patch)
tree5fb650d2033f2d9c3f83aad548244ffbcd434bb8 /kde-base/kdelibs
parentChanged herd for sci-biology (diff)
downloadgentoo-2-49edea1b55bae5ec0124a231d4c5090a8fcc437f.tar.gz
gentoo-2-49edea1b55bae5ec0124a231d4c5090a8fcc437f.tar.bz2
gentoo-2-49edea1b55bae5ec0124a231d4c5090a8fcc437f.zip
Add patch to fix Konqueror crash. Patch from Dirk Mueller <mueller@kde.org>, thanks to Hanno Boeck for reporting. See bug #141173.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/ChangeLog9
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.5.3-r46
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch13
-rw-r--r--kde-base/kdelibs/kdelibs-3.5.3-r4.ebuild174
4 files changed, 201 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index fb6813363e4a..4e9942c06c6d 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.346 2006/07/17 02:11:44 psi29a Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.347 2006/07/20 18:12:51 flameeyes Exp $
+
+*kdelibs-3.5.3-r4 (20 Jul 2006)
+
+ 20 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kdelibs-3.5.3-konqcrash.patch, +kdelibs-3.5.3-r4.ebuild:
+ Add patch to fix Konqueror crash. Patch from Dirk Mueller <mueller@kde.org>,
+ thanks to Hanno Boeck for reporting. See bug #141173.
16 Jul 2006; <psi29a@gentoo.org> kdelibs-3.5.2-r6.ebuild:
marked as stable
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.5.3-r4 b/kde-base/kdelibs/files/digest-kdelibs-3.5.3-r4
new file mode 100644
index 000000000000..d6d1bffc9da9
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.5.3-r4
@@ -0,0 +1,6 @@
+MD5 08fe95f3fbe2301d14e5f237ed81bc1a kdelibs-3.5-patchset-03.tar.bz2 16346
+RMD160 067ca7474b987dac704f8e350cb8af57e632ce8d kdelibs-3.5-patchset-03.tar.bz2 16346
+SHA256 a2a16afe41617a363bc59733bf76747fb4635243bfa7007374ccb44cff8cd04e kdelibs-3.5-patchset-03.tar.bz2 16346
+MD5 972c2c6855f912179bd7830bf2ed91d8 kdelibs-3.5.3.tar.bz2 15424888
+RMD160 be39edfea7bfe1f0c0408be8fe9f37077954e545 kdelibs-3.5.3.tar.bz2 15424888
+SHA256 ff394fba46b353e3a1c27175788f428fa3561849b18ef744a1252c34bf09fdb9 kdelibs-3.5.3.tar.bz2 15424888
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch b/kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch
new file mode 100644
index 000000000000..13ec8de97f8d
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch
@@ -0,0 +1,13 @@
+Index: khtml/dom/dom_node.cpp
+===================================================================
+--- khtml/dom/dom_node.cpp (revision 562181)
++++ khtml/dom/dom_node.cpp (revision 562182)
+@@ -273,7 +273,7 @@
+ NodeImpl *r = impl->replaceChild( newChild.impl, oldChild.impl, exceptioncode );
+ if (exceptioncode)
+ throw DOMException(exceptioncode);
+- if (!newChild.impl->closed()) newChild.impl->close();
++ if (newChild.impl && !newChild.impl->closed()) newChild.impl->close();
+ return r;
+ }
+
diff --git a/kde-base/kdelibs/kdelibs-3.5.3-r4.ebuild b/kde-base/kdelibs/kdelibs-3.5.3-r4.ebuild
new file mode 100644
index 000000000000..15debc61ca88
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.5.3-r4.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.5.3-r4.ebuild,v 1.1 2006/07/20 18:12:51 flameeyes Exp $
+
+inherit kde flag-o-matic eutils multilib
+set-kdedir 3.5
+
+DESCRIPTION="KDE libraries needed by all kde programs"
+HOMEPAGE="http://www.kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/${P}.tar.bz2
+ mirror://gentoo/kdelibs-3.5-patchset-03.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.5"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="acl alsa arts cups doc jpeg2k kerberos legacyssl openexr spell ssl tiff
+zeroconf kernel_linux fam"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+
+# Added aspell-en as dependency to work around bug 131512.
+RDEPEND="$(qt_min_version 3.3.3)
+ arts? ( ~kde-base/arts-${PV} )
+ app-arch/bzip2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ >=dev-libs/libxslt-1.1.15
+ >=dev-libs/libxml2-2.6.6
+ >=dev-libs/libpcre-4.2
+ media-libs/libart_lgpl
+ net-dns/libidn
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ alsa? ( media-libs/alsa-lib )
+ cups? ( >=net-print/cups-1.1.19 )
+ tiff? ( media-libs/tiff )
+ kerberos? ( virtual/krb5 )
+ jpeg2k? ( media-libs/jasper )
+ openexr? ( >=media-libs/openexr-1.2 )
+ spell? ( || ( ( app-text/aspell app-dicts/aspell-en )
+ app-text/ispell ) )
+ zeroconf? ( net-misc/mDNSResponder )
+ fam? ( virtual/fam )
+ virtual/ghostscript"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+RDEPEND="${RDEPEND}
+ || ( ( x11-apps/rgb x11-apps/iceauth ) <virtual/x11-7 )"
+
+PATCHES="${FILESDIR}/${P}-konqcrash.patch"
+
+pkg_setup() {
+ if use legacyssl ; then
+ echo ""
+ eerror "Warning:"
+ ewarn "You have the legacyssl use flag enabled, which fixes issues with some broken"
+ ewarn "sites, but breaks others instead. It is strongly discouraged to use it."
+ ewarn "For more information, see bug #128922."
+ echo ""
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ if use legacyssl ; then
+ # This patch won't be included upstream, see bug #128922
+ epatch ${WORKDIR}/patches/kdelibs-3.5.2-kssl-3des.patch || die "Patch did not apply."
+ fi
+
+ if use cups && has_version '>=net-print/cups-1.2_pre'; then
+ cd "${S}"
+
+ EPATCH_EXCLUDE="kubuntu_39_cups12_compile_fixes.diff" \
+ EPATCH_SUFFIX="diff" \
+ EPATCH_MULTI_MSG="Applying KUbuntu patches for CUPS 1.2 support ..." \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}/kdeprint-3.5.2-cups-1.2-patches/"
+ fi
+}
+
+src_compile() {
+ rm -f ${S}/configure
+
+ # hspell is disabled because it requires version 0.9 of hspell that
+ # is not in portage yet; leaving it to autodetection tries to use it
+ # and then fails because of missing required functions
+
+ myconf="--with-distribution=Gentoo
+ $(use_enable fam libfam) $(use_enable kernel_linux dnotify)
+ --with-libart --with-libidn --without-utempter
+ $(use_with acl) $(use_with ssl)
+ $(use_with alsa) $(use_with arts)
+ $(use_with kerberos gssapi) $(use_with tiff)
+ $(use_with jpeg2k jasper) $(use_with openexr)
+ $(use_enable cups) $(use_enable zeroconf dnssd)
+ --without-hspell"
+
+ if use spell && has_version app-text/aspell; then
+ myconf="${myconf} --with-aspell"
+ else
+ myconf="${myconf} --without-aspell"
+ fi
+
+ if has_version x11-apps/rgb; then
+ myconf="${myconf} --with-rgbfile=/usr/share/X11/rgb.txt"
+ fi
+
+ myconf="${myconf} --disable-fast-malloc"
+
+ # fix bug 58179, bug 85593
+ # kdelibs-3.4.0 needed -fno-gcse; 3.4.1 needs -mminimal-toc; this needs a
+ # closer look... - corsair
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # work around bug #120858, gcc 3.4.x -Os miscompilation
+ use x86 && replace-flags "-Os" "-O2" # see bug #120858
+
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+
+ kde_src_compile
+
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ # Needed to create lib -> lib64 symlink for amd64 2005.0 profile
+ if [ "${SYMLINK_LIB}" = "yes" ]; then
+ dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) ${KDEDIR}/lib
+ fi
+
+ if ! use arts ; then
+ dodir /etc/env.d
+
+ # List all the multilib libdirs
+ local libdirs
+ for libdir in $(get_all_libdirs); do
+ libdirs="${libdirs}:${PREFIX}/${libdir}"
+ done
+
+ cat <<EOF > ${D}/etc/env.d/45kdepaths-${SLOT} # number goes down with version upgrade
+PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${libdirs:1}
+CONFIG_PROTECT="${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown"
+EOF
+ fi
+
+}
+
+pkg_postinst() {
+ if use zeroconf; then
+ echo
+ einfo "To make zeroconf support available in KDE"
+ einfo "make sure that the 'mdnsd' daemon is running."
+ einfo "Make sure also that multicast dns lookups are"
+ einfo "enabled by editing the 'hosts:' line in"
+ einfo "/etc/nsswitch.conf to include 'mdns', e.g.:"
+ einfo "hosts: files mdns dns"
+ echo
+ fi
+}