summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commitb5c71598bd396d68feb09813aad0c75a45f81a3a (patch)
treeb738e19f08caad8c28f1ee6bee7051613495e2de /kde-base/kdepim-runtime
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadgentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.gz
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.bz2
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.zip
Version bump KDE SC 4.11.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog8
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.11.2.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 689274219481..59b478fdffcb 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.160 2013/09/03 19:50:01 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.161 2013/10/09 23:03:53 creffett Exp $
+
+*kdepim-runtime-4.11.2 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org>
+ +kdepim-runtime-4.11.2.ebuild:
+ Version bump KDE SC 4.11.2
03 Sep 2013; Chris Reffett <creffett@gentoo.org>
-kdepim-runtime-4.11.0.ebuild:
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.11.2.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.11.2.ebuild
new file mode 100644
index 000000000000..7e32c2b60cb3
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.11.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.11.2.ebuild,v 1.1 2013/10/09 23:03:53 creffett Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.9.52
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+ !kde-misc/akonadi-facebook
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}