summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
commit461c1af9ab4c8cfbdc911a491f7c86af2ef043dd (patch)
tree05608ce8b58bb6826c888fa542fb8c351b8e650b /kde-base/kdeplasma-addons
parentUse QA_PREBUILT, fix minor QA issues, wrt bug #430026 (diff)
downloadgentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.gz
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.bz2
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.zip
Version bump KDE SC 4.9.5
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog9
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.9.5.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index e5310ed4bcfc..8f3db794c4f9 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeplasma-addons
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.161 2012/12/23 19:27:45 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.162 2013/01/05 20:18:40 creffett Exp $
+
+*kdeplasma-addons-4.9.5 (05 Jan 2013)
+
+ 05 Jan 2013; <creffett@gentoo.org> +kdeplasma-addons-4.9.5.ebuild:
+ Version bump KDE SC 4.9.5
23 Dec 2012; Markus Meier <maekke@gentoo.org> kdeplasma-addons-4.9.4.ebuild:
add ~arm
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.5.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.5.ebuild
new file mode 100644
index 000000000000..4d66352f12bd
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.5.ebuild,v 1.1 2013/01/05 20:18:40 creffett Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus json oauth qalculate qwt scim
+semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ json? ( dev-libs/qjson )
+ oauth? ( dev-libs/qoauth )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with ibus)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}