summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 22:55:20 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 22:55:20 +0000
commit6209712910eb266971bde25b21eab6033d2dc27b (patch)
treeea1859d38280d0b39243a0a12510d1eb05d8c34e /kde-base/kdesktop
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-6209712910eb266971bde25b21eab6033d2dc27b.tar.gz
gentoo-2-6209712910eb266971bde25b21eab6033d2dc27b.tar.bz2
gentoo-2-6209712910eb266971bde25b21eab6033d2dc27b.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kdesktop')
-rw-r--r--kde-base/kdesktop/ChangeLog8
-rw-r--r--kde-base/kdesktop/kdesktop-3.5.9.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/kdesktop/ChangeLog b/kde-base/kdesktop/ChangeLog
index d148acdf2f45..5d3410043359 100644
--- a/kde-base/kdesktop/ChangeLog
+++ b/kde-base/kdesktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdesktop
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.106 2008/02/17 01:59:23 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.107 2008/02/20 22:55:20 philantrop Exp $
+
+*kdesktop-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdesktop-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/kdesktop-3.5.5-seli-xinerama.patch, -kdesktop-3.5.5.ebuild,
diff --git a/kde-base/kdesktop/kdesktop-3.5.9.ebuild b/kde-base/kdesktop/kdesktop-3.5.9.ebuild
new file mode 100644
index 000000000000..d2c2e2ff0095
--- /dev/null
+++ b/kde-base/kdesktop/kdesktop-3.5.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.9.ebuild,v 1.1 2008/02/20 22:55:20 philantrop Exp $
+
+KMNAME=kdebase
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-05.tar.bz2"
+
+DESCRIPTION="KDesktop is the KDE interface that handles the icons, desktop popup menus and screensaver system."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xscreensaver"
+
+DEPEND=">=kde-base/libkonq-${PV}:${SLOT}
+ >=kde-base/kcontrol-${PV}:${SLOT}
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+ >=kde-base/kcheckpass-${PV}:${SLOT}
+ >=kde-base/kdialog-${PV}:${SLOT}
+ >=kde-base/konqueror-${PV}:${SLOT}
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+ libkonq/
+ kdm/kfrontend/themer/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+ kdmlib/"
+KMNODOCS=true
+
+src_unpack() {
+ kde-meta_src_unpack
+ # see bug #143375
+ sed -e "s:SUBDIRS = . lock pics patterns programs init:SUBDIRS = . lock pics patterns programs:" \
+ -i kdesktop/Makefile.am
+}
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+ kde-meta_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ dodir "${PREFIX}"/share/templates/.source/emptydir
+}