summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-16 18:26:42 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-16 18:26:42 +0000
commit48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3 (patch)
tree8fa78b82fe5cd62ff7393c94992cbc8552cf9c4b /kde-base/kig
parentversion bump (diff)
downloadgentoo-2-48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3.tar.gz
gentoo-2-48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3.tar.bz2
gentoo-2-48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3.zip
Version bump KDE SC 4.13.0
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kig')
-rw-r--r--kde-base/kig/ChangeLog7
-rw-r--r--kde-base/kig/kig-4.13.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kig/ChangeLog b/kde-base/kig/ChangeLog
index 34237e3b9bff..e44151d05cdf 100644
--- a/kde-base/kig/ChangeLog
+++ b/kde-base/kig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kig
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.315 2014/04/01 18:24:17 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.316 2014/04/16 18:26:12 johu Exp $
+
+*kig-4.13.0 (16 Apr 2014)
+
+ 16 Apr 2014; Johannes Huber <johu@gentoo.org> +kig-4.13.0.ebuild:
+ Version bump KDE SC 4.13.0
01 Apr 2014; Johannes Huber <johu@gentoo.org>
files/kig-4.12.0-boostpython.patch:
diff --git a/kde-base/kig/kig-4.13.0.ebuild b/kde-base/kig/kig-4.13.0.ebuild
new file mode 100644
index 000000000000..12833590adac
--- /dev/null
+++ b/kde-base/kig/kig-4.13.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-4.13.0.ebuild,v 1.1 2014/04/16 18:26:12 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="http://www.kde.org/applications/education/kig http://edu.kde.org/kig"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde4-base_src_configure
+}