summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:37:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:37:22 +0000
commite63488f9219650a59e573313749a24276e381cb4 (patch)
tree5d53df7562a401e6b9b70aad2059de2ea0df882b /kde-base/kmail
parentFull auto: Version bump for KDE-4.1.3 (diff)
downloadgentoo-2-e63488f9219650a59e573313749a24276e381cb4.tar.gz
gentoo-2-e63488f9219650a59e573313749a24276e381cb4.tar.bz2
gentoo-2-e63488f9219650a59e573313749a24276e381cb4.zip
Full auto: Version bump for KDE-4.1.3
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/kmail-4.1.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 6d0d1b057f63..bc666aa35f20 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.140 2008/11/03 17:05:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.141 2008/11/09 01:37:21 scarabeus Exp $
+
+*kmail-4.1.3 (08 Nov 2008)
+
+ 08 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +kmail-4.1.3.ebuild:
+ Version bump.
03 Nov 2008; Mike Frysinger <vapier@gentoo.org> kmail-4.1.2.ebuild:
Add -mminimal-toc for ppc64 systems.
diff --git a/kde-base/kmail/kmail-4.1.3.ebuild b/kde-base/kmail/kmail-4.1.3.ebuild
new file mode 100644
index 000000000000..f849cf8763d8
--- /dev/null
+++ b/kde-base/kmail/kmail-4.1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.1.3.ebuild,v 1.1 2008/11/09 01:37:22 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdepim
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook +nepomuk"
+
+DEPEND=">=kde-base/libkdepim-${PV}:${SLOT}
+ >=kde-base/libkleo-${PV}:${SLOT}
+ >=kde-base/libkpgp-${PV}:${SLOT}
+ >=kde-base/libksieve-${PV}:${SLOT}
+ >=kde-base/mimelib-${PV}:${SLOT}
+ nepomuk? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+
+RDEPEND="${DEPEND}
+ >=kde-base/kmailcvt-${PV}:${SLOT}"
+
+KMEXTRACTONLY="
+ libkdepim
+ libkleo
+ libkpgp
+ kaddressbook/org.kde.KAddressbook.Core.xml
+ korganizer/org.kde.Korganizer.Calendar.xml
+ mimelib
+ kdepim-compat.h
+"
+KMEXTRA="${KMEXTRA} plugins/kmail/"
+KMLOADLIBS="libkdepim"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with nepomuk Nepomuk)"
+
+ kde4-meta_src_configure
+}