summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
commita7d39b161d3ea87618db515020379fc2be385858 (patch)
tree3fd47e295f81d71610e045a95b9b7a70e5373756 /kde-base/kontact
parentAdd systemd support (#466084) (diff)
downloadgentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.gz
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.bz2
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.zip
Bump KDE to 4.1.1
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kontact')
-rw-r--r--kde-base/kontact/ChangeLog7
-rw-r--r--kde-base/kontact/kontact-4.11.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/kontact/ChangeLog b/kde-base/kontact/ChangeLog
index a8e04169de46..9c1643f3c527 100644
--- a/kde-base/kontact/ChangeLog
+++ b/kde-base/kontact/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kontact
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.283 2013/08/14 20:23:39 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.284 2013/09/03 19:04:09 creffett Exp $
+
+*kontact-4.11.1 (03 Sep 2013)
+
+ 03 Sep 2013; Chris Reffett <creffett@gentoo.org> +kontact-4.11.1.ebuild:
+ Bump KDE to 4.1.1
*kontact-4.11.0 (14 Aug 2013)
diff --git a/kde-base/kontact/kontact-4.11.1.ebuild b/kde-base/kontact/kontact-4.11.1.ebuild
new file mode 100644
index 000000000000..0487e0797564
--- /dev/null
+++ b/kde-base/kontact/kontact-4.11.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.11.1.ebuild,v 1.1 2013/09/03 19:04:09 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+HOMEPAGE="http://www.kde.org/applications/office/kontact/"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="kdepim-common-libs"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+KMEXTRACTONLY="
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ libkdepimdbusinterfaces/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}