summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-01 18:24:17 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-01 18:24:17 +0000
commit979f75aec1bf9b5d988273d9b064f73b74df6167 (patch)
tree5d7f29b85b201177ed8a040a99281478edfd4781 /kde-base/ksplash
parentVersion bump KDE SC 4.12.4 (diff)
downloadgentoo-2-979f75aec1bf9b5d988273d9b064f73b74df6167.tar.gz
gentoo-2-979f75aec1bf9b5d988273d9b064f73b74df6167.tar.bz2
gentoo-2-979f75aec1bf9b5d988273d9b064f73b74df6167.zip
Version bump KDE Workspace 4.11.8
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.11.8.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 11f5cc251467..74136602ac3e 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.214 2014/03/11 13:32:14 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.215 2014/04/01 18:24:13 johu Exp $
+
+*ksplash-4.11.8 (01 Apr 2014)
+
+ 01 Apr 2014; Johannes Huber <johu@gentoo.org> +ksplash-4.11.8.ebuild:
+ Version bump KDE Workspace 4.11.8
11 Mar 2014; Johannes Huber <johu@gentoo.org> -ksplash-4.11.6.ebuild:
Remove KDE Workspace 4.11.6
diff --git a/kde-base/ksplash/ksplash-4.11.8.ebuild b/kde-base/ksplash/ksplash-4.11.8.ebuild
new file mode 100644
index 000000000000..de7d666e0ac9
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.11.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.11.8.ebuild,v 1.1 2014/04/01 18:24:13 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}