summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-06 23:54:29 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-06 23:54:29 +0000
commita85d0788dab66477565d411200c58bf44598b5a6 (patch)
treecbe2cfb5e5927aaa6c95f7d2e95183360d7910e8 /kde-base/ksplash
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-a85d0788dab66477565d411200c58bf44598b5a6.tar.gz
gentoo-2-a85d0788dab66477565d411200c58bf44598b5a6.tar.bz2
gentoo-2-a85d0788dab66477565d411200c58bf44598b5a6.zip
Version bump KDE 4.2.3
(Portage version: 2.2_rc31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.2.3.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 78c49353b116..e29a434a0db2 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.26 2009/04/17 06:35:52 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.27 2009/05/06 23:54:29 scarabeus Exp $
+
+*ksplash-4.2.3 (06 May 2009)
+
+ 06 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +ksplash-4.2.3.ebuild:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> -ksplash-4.2.1.ebuild,
ksplash-4.2.2:
diff --git a/kde-base/ksplash/ksplash-4.2.3.ebuild b/kde-base/ksplash/ksplash-4.2.3.ebuild
new file mode 100644
index 000000000000..7770c0b3edbf
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.2.3.ebuild,v 1.1 2009/05/06 23:54:29 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}