summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
commitc106175041331c114244227a14b1c3242fe799ee (patch)
treee16e2d4ee461b8ac893f1113d86a29e0b20658b8 /kde-base/ksplash
parentAdd patch to support >=gtk-2.24.0. #460714 (diff)
downloadgentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.gz
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.bz2
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.zip
Version bump KDE SC 4.10.2
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog8
-rw-r--r--kde-base/ksplash/ksplash-4.10.2.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index e8566116fbec..48d6026f540c 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.164 2013/04/02 20:51:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.165 2013/04/06 00:04:22 dilfridge Exp $
+
+*ksplash-4.10.2 (05 Apr 2013)
+
+ 05 Apr 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ksplash-4.10.2.ebuild:
+ Version bump KDE SC 4.10.2
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> ksplash-4.10.1.ebuild:
Stable for ppc64, wrt to bug #462890
diff --git a/kde-base/ksplash/ksplash-4.10.2.ebuild b/kde-base/ksplash/ksplash-4.10.2.ebuild
new file mode 100644
index 000000000000..02b06c109030
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.10.2.ebuild,v 1.1 2013/04/06 00:04:22 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}