summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commita4c1d03d518d1416c826bb73ad524dc9bf1702a5 (patch)
treed6a50377f609e5e7550ca8a99686adcdcbdbd7a1 /kde-base/ksystemlog
parentRemoved unneccessary python_copy_sources (diff)
downloadgentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.gz
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.bz2
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.zip
[kde-base] Add KDE SC 4.6.1
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.6.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 87f4057cefcb..6627ef917c30 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.64 2011/01/26 20:28:49 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.65 2011/03/04 18:00:07 alexxy Exp $
+
+*ksystemlog-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksystemlog-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*ksystemlog-4.6.0 (26 Jan 2011)
diff --git a/kde-base/ksystemlog/ksystemlog-4.6.1.ebuild b/kde-base/ksystemlog/ksystemlog-4.6.1.ebuild
new file mode 100644
index 000000000000..7c02b0093499
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.6.1.ebuild,v 1.1 2011/03/04 18:00:07 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+
+VIRTUALX_REQUIRED=tests
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}