summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-11-13 20:21:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-11-13 20:21:30 +0000
commit32382dc86f8823bcda5bdd758624f60c2fb8c0d5 (patch)
treef40084028e5a35f758897da863ef069bd3cf06ea /kde-base/pykde4
parentStable for HPPA (bug #438804). (diff)
downloadgentoo-2-32382dc86f8823bcda5bdd758624f60c2fb8c0d5.tar.gz
gentoo-2-32382dc86f8823bcda5bdd758624f60c2fb8c0d5.tar.bz2
gentoo-2-32382dc86f8823bcda5bdd758624f60c2fb8c0d5.zip
Remove KDE SC 4.9.2
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog6
-rw-r--r--kde-base/pykde4/pykde4-4.9.2-r1.ebuild161
-rw-r--r--kde-base/pykde4/pykde4-4.9.2.ebuild157
3 files changed, 5 insertions, 319 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 13733d18ee72..27b8b36004d9 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.182 2012/11/13 20:04:40 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.183 2012/11/13 20:21:29 johu Exp $
+
+ 13 Nov 2012; Johannes Huber <johu@gentoo.org> -pykde4-4.9.2.ebuild,
+ -pykde4-4.9.2-r1.ebuild:
+ Remove KDE SC 4.9.2
13 Nov 2012; Johannes Huber <johu@gentoo.org> -pykde4-4.9.1.ebuild:
Remove KDE SC 4.9.1
diff --git a/kde-base/pykde4/pykde4-4.9.2-r1.ebuild b/kde-base/pykde4/pykde4-4.9.2-r1.ebuild
deleted file mode 100644
index 3e618ac3a6ce..000000000000
--- a/kde-base/pykde4/pykde4-4.9.2-r1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.9.2-r1.ebuild,v 1.2 2012/10/17 19:39:24 maekke Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="*:2.5"
-RESTRICT_PYTHON_ABIS="*-jython 2.4 2.7-pypy-*"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-
-OPENGL_REQUIRED="always"
-inherit python portability kde4-base multilib
-
-DESCRIPTION="Python bindings for KDE4"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples semantic-desktop"
-REQUIRED_USE="test? ( semantic-desktop )"
-
-# blocker added due to compatibility issues and error during compile time
-RDEPEND="
- >=dev-python/sip-4.14
- $(add_kdebase_dep kdelibs 'opengl,semantic-desktop=')
- semantic-desktop? (
- $(add_kdebase_dep kdepimlibs 'semantic-desktop')
- >=dev-libs/soprano-2.8.0
- )
- aqua? ( >=dev-python/PyQt4-4.9.5[dbus,declarative,sql,svg,webkit,aqua] )
- !aqua? ( >=dev-python/PyQt4-4.9.5[dbus,declarative,sql,svg,webkit,X] )
-"
-DEPEND="${RDEPEND}
- sys-devel/libtool
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-pyqt45.patch
-)
-
-pkg_setup() {
- python_pkg_setup
- kde4-base_pkg_setup
-
- have_python2=false
-
- scan_python_versions() {
- [[ ${PYTHON_ABI} == 2.* ]] && have_python2=true
- :
- }
- python_execute_function -q scan_python_versions
- if ! ${have_python2}; then
- ewarn "You do not have a Python 2 version selected."
- ewarn "kpythonpluginfactory will not be built"
- fi
-}
-
-src_prepare() {
- kde4-base_src_prepare
-
- if ! use examples; then
- sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i CMakeLists.txt \
- || die "Failed to disable examples"
- fi
-
- # See bug 322351
- use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
-
- sed -i -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' kpythonpluginfactory/CMakeLists.txt
-
- if ${have_python2}; then
- mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
- cp "${FILESDIR}/kpythonpluginfactorywrapper.c-r1" "${WORKDIR}/wrapper/kpythonpluginfactorywrapper.c" || die "failed to copy wrapper"
- fi
-}
-
-src_configure() {
- configuration() {
- local mycmakeargs=(
- -DWITH_PolkitQt=OFF
- -DWITH_QScintilla=OFF
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with semantic-desktop KdepimLibs)
- -DPYTHON_EXECUTABLE=$(PYTHON -a)
- )
- local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
- kde4-base_src_configure
- }
-
- python_execute_function configuration
-}
-
-echo_and_run() {
- echo "$@"
- "$@"
-}
-
-src_compile() {
- compilation() {
- local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
- kde4-base_src_compile
- }
- python_execute_function compilation
-
- if ${have_python2}; then
- cd "${WORKDIR}/wrapper"
- echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
- -shared \
- ${CFLAGS} ${CPPFLAGS} \
- -DEPREFIX="\"${EPREFIX}\"" \
- -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
- -o kpythonpluginfactorywrapper.lo \
- kpythonpluginfactorywrapper.c
- echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
- -shared -module -avoid-version \
- ${CFLAGS} ${LDFLAGS} \
- -o kpythonpluginfactory.la \
- -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
- kpythonpluginfactorywrapper.lo \
- $(dlopen_lib)
- fi
-}
-
-src_install() {
- installation() {
- cd "${S}_build-${PYTHON_ABI}"
- emake DESTDIR="${T}/images/${PYTHON_ABI}" install
- }
- python_execute_function installation
-
- python_merge_intermediate_installation_images "${T}/images"
-
- # As we don't call the eclass's src_install, we have to install the docs manually
- DOCS=("${S}"/{AUTHORS,NEWS,README})
- use doc && HTML_DOCS=("${S}/docs/html/")
- base_src_install_docs
-
- if ${have_python2}; then
- cd "${WORKDIR}/wrapper"
- echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
- rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
- fi
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- python_mod_optimize PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
-
- if use examples; then
- echo
- elog "PyKDE4 examples have been installed to"
- elog "${EPREFIX}/usr/share/apps/${PN}/examples"
- echo
- fi
-}
-
-pkg_postrm() {
- kde4-base_pkg_postrm
-
- python_mod_cleanup PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
-}
diff --git a/kde-base/pykde4/pykde4-4.9.2.ebuild b/kde-base/pykde4/pykde4-4.9.2.ebuild
deleted file mode 100644
index 6742d926cef3..000000000000
--- a/kde-base/pykde4/pykde4-4.9.2.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.9.2.ebuild,v 1.1 2012/10/02 18:12:09 johu Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="*:2.5"
-RESTRICT_PYTHON_ABIS="*-jython 2.4 2.7-pypy-*"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-
-OPENGL_REQUIRED="always"
-inherit python portability kde4-base multilib
-
-DESCRIPTION="Python bindings for KDE4"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples semantic-desktop"
-REQUIRED_USE="test? ( semantic-desktop )"
-
-# blocker added due to compatibility issues and error during compile time
-RDEPEND="
- >=dev-python/sip-4.13.1
- $(add_kdebase_dep kdelibs 'opengl,semantic-desktop=')
- semantic-desktop? (
- $(add_kdebase_dep kdepimlibs 'semantic-desktop')
- >=dev-libs/soprano-2.8.0
- )
- aqua? ( >=dev-python/PyQt4-4.9[dbus,declarative,sql,svg,webkit,aqua] )
- !aqua? ( >=dev-python/PyQt4-4.9[dbus,declarative,sql,svg,webkit,X] )
-"
-DEPEND="${RDEPEND}
- sys-devel/libtool
-"
-
-pkg_setup() {
- python_pkg_setup
- kde4-base_pkg_setup
-
- have_python2=false
-
- scan_python_versions() {
- [[ ${PYTHON_ABI} == 2.* ]] && have_python2=true
- :
- }
- python_execute_function -q scan_python_versions
- if ! ${have_python2}; then
- ewarn "You do not have a Python 2 version selected."
- ewarn "kpythonpluginfactory will not be built"
- fi
-}
-
-src_prepare() {
- kde4-base_src_prepare
-
- if ! use examples; then
- sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i CMakeLists.txt \
- || die "Failed to disable examples"
- fi
-
- # See bug 322351
- use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
-
- sed -i -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' kpythonpluginfactory/CMakeLists.txt
-
- if ${have_python2}; then
- mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
- cp "${FILESDIR}/kpythonpluginfactorywrapper.c-r1" "${WORKDIR}/wrapper/kpythonpluginfactorywrapper.c" || die "failed to copy wrapper"
- fi
-}
-
-src_configure() {
- configuration() {
- local mycmakeargs=(
- -DWITH_PolkitQt=OFF
- -DWITH_QScintilla=OFF
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with semantic-desktop KdepimLibs)
- -DPYTHON_EXECUTABLE=$(PYTHON -a)
- )
- local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
- kde4-base_src_configure
- }
-
- python_execute_function configuration
-}
-
-echo_and_run() {
- echo "$@"
- "$@"
-}
-
-src_compile() {
- compilation() {
- local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
- kde4-base_src_compile
- }
- python_execute_function compilation
-
- if ${have_python2}; then
- cd "${WORKDIR}/wrapper"
- echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
- -shared \
- ${CFLAGS} ${CPPFLAGS} \
- -DEPREFIX="\"${EPREFIX}\"" \
- -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
- -o kpythonpluginfactorywrapper.lo \
- kpythonpluginfactorywrapper.c
- echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
- -shared -module -avoid-version \
- ${CFLAGS} ${LDFLAGS} \
- -o kpythonpluginfactory.la \
- -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
- kpythonpluginfactorywrapper.lo \
- $(dlopen_lib)
- fi
-}
-
-src_install() {
- installation() {
- cd "${S}_build-${PYTHON_ABI}"
- emake DESTDIR="${T}/images/${PYTHON_ABI}" install
- }
- python_execute_function installation
-
- python_merge_intermediate_installation_images "${T}/images"
-
- # As we don't call the eclass's src_install, we have to install the docs manually
- DOCS=("${S}"/{AUTHORS,NEWS,README})
- use doc && HTML_DOCS=("${S}/docs/html/")
- base_src_install_docs
-
- if ${have_python2}; then
- cd "${WORKDIR}/wrapper"
- echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
- rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
- fi
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- python_mod_optimize PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
-
- if use examples; then
- echo
- elog "PyKDE4 examples have been installed to"
- elog "${EPREFIX}/usr/share/apps/${PN}/examples"
- echo
- fi
-}
-
-pkg_postrm() {
- kde4-base_pkg_postrm
-
- python_mod_cleanup PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
-}