summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-09-11 02:24:03 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-09-11 02:24:03 +0000
commit4f36de1d780b23f0e43cc3d49166a244d5ab7684 (patch)
tree6f4fbf3ea036313413fabdcbb6b075dc2913d52d /kde-base/pykde4
parentVersion bump (diff)
downloadgentoo-2-4f36de1d780b23f0e43cc3d49166a244d5ab7684.tar.gz
gentoo-2-4f36de1d780b23f0e43cc3d49166a244d5ab7684.tar.bz2
gentoo-2-4f36de1d780b23f0e43cc3d49166a244d5ab7684.zip
[kde-base/pykde4-4.5.1-r1] Added ebuild back with the mapped type patch. Added explicit deps for >dev-python/PyQt4-4.7.3 and >dev-python/sip-4.10. Fixes bug 332503.
(Portage version: 2.2_rc76/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/pykde4-4.5.1-r1.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 4deaaaafafbf..09d1525961b8 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.89 2010/09/07 12:58:27 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.90 2010/09/11 02:24:02 jmbsvicetto Exp $
+
+ 11 Sep 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +pykde4-4.5.1-r1.ebuild:
+ [kde-base/pykde4-4.5.1-r1] Added ebuild back with the mapped type patch.
+ Added explicit deps for >dev-python/PyQt4-4.7.3 and >dev-python/sip-4.10.
+ Fixes bug 332503.
*pykde4-4.5.1 (07 Sep 2010)
diff --git a/kde-base/pykde4/pykde4-4.5.1-r1.ebuild b/kde-base/pykde4/pykde4-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..ecb670215fa2
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.5.1-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.5.1-r1.ebuild,v 1.4 2010/09/11 02:24:03 jmbsvicetto Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="python/pykde4"
+OPENGL_REQUIRED="always"
+PYTHON_USE_WITH="threads"
+RESTRICT_PYTHON_ABIS="2.4"
+inherit python kde4-meta
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc examples semantic-desktop"
+
+# blocker added due to compatibility issues and error during compile time
+# Added specific PyQt4 and sip deps to fix bug 332503.
+DEPEND="
+ !dev-python/pykde
+ >dev-python/PyQt4-4.7.3
+ >dev-python/sip-4.10
+ $(add_kdebase_dep kdelibs 'opengl,semantic-desktop?')
+ semantic-desktop? ( $(add_kdebase_dep kdepimlibs 'semantic-desktop') )
+ aqua? ( >=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,aqua] )
+ !aqua? ( >=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,X] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-mapped-type-fix.patch" )
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i python/${PN}/CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_QScintilla=OFF
+ -DWITH_PolkitQt=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${S}/python/pykde4/docs/html/")
+
+ kde4-meta_src_install
+
+ python_convert_shebangs -q -r $(python_get_version) "${ED}"
+ python_clean_installation_image -q
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ python_mod_optimize PyKDE4 PyQt4
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EKDEDIR}/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+
+ python_mod_cleanup PyKDE4 PyQt4
+}