summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-03 19:04:59 +0000
commita7d39b161d3ea87618db515020379fc2be385858 (patch)
tree3fd47e295f81d71610e045a95b9b7a70e5373756 /kde-base/rocs
parentAdd systemd support (#466084) (diff)
downloadgentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.gz
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.tar.bz2
gentoo-2-a7d39b161d3ea87618db515020379fc2be385858.zip
Bump KDE to 4.1.1
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/rocs')
-rw-r--r--kde-base/rocs/ChangeLog7
-rw-r--r--kde-base/rocs/rocs-4.11.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/rocs/ChangeLog b/kde-base/rocs/ChangeLog
index 66c7aec2c74c..8afb36cb23c9 100644
--- a/kde-base/rocs/ChangeLog
+++ b/kde-base/rocs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/rocs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.130 2013/08/14 20:23:38 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.131 2013/09/03 19:04:35 creffett Exp $
+
+*rocs-4.11.1 (03 Sep 2013)
+
+ 03 Sep 2013; Chris Reffett <creffett@gentoo.org> +rocs-4.11.1.ebuild:
+ Bump KDE to 4.1.1
*rocs-4.11.0 (14 Aug 2013)
diff --git a/kde-base/rocs/rocs-4.11.1.ebuild b/kde-base/rocs/rocs-4.11.1.ebuild
new file mode 100644
index 000000000000..e02485208546
--- /dev/null
+++ b/kde-base/rocs/rocs-4.11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.11.1.ebuild,v 1.1 2013/09/03 19:04:35 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface to work with Graph Theory"
+HOMEPAGE="http://www.kde.org/applications/education/rocs
+http://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/grantlee
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT=test
+# bug 443752
+
+src_test() {
+ local mycmakeargs=(-DKDE4_BUILD_TESTS=ON)
+ cmake-utils_src_configure
+ kde4-base_src_compile
+
+ cd "${CMAKE_BUILD_DIR}"
+ emake DESTDIR="${T}/tests" install
+ export KDEDIRS="${KDEDIRS}:${T}/tests/${PREFIX}"
+ kbuildsycoca4
+ ctest || die "tests failed"
+}