summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
committerJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
commitb5a8b2e1508f119b3da9007782069d7554f7973d (patch)
tree3039b14e2a5b6b94c65ead7c9d1b9e21cdab1b44 /kde-base/rocs
parentStable for x86, wrt bug #520220 (diff)
downloadgentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.gz
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.bz2
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.zip
Version bump KDE SC 4.14.0
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/rocs')
-rw-r--r--kde-base/rocs/ChangeLog7
-rw-r--r--kde-base/rocs/rocs-4.14.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/rocs/ChangeLog b/kde-base/rocs/ChangeLog
index 679ec2d8b3a2..b5621436de89 100644
--- a/kde-base/rocs/ChangeLog
+++ b/kde-base/rocs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/rocs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.172 2014/07/23 16:52:57 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.173 2014/08/20 16:02:42 johu Exp $
+
+*rocs-4.14.0 (20 Aug 2014)
+
+ 20 Aug 2014; Johannes Huber <johu@gentoo.org> +rocs-4.14.0.ebuild:
+ Version bump KDE SC 4.14.0
23 Jul 2014; Johannes Huber <johu@gentoo.org> -rocs-4.13.2.ebuild:
Remove KDE SC 4.13.2
diff --git a/kde-base/rocs/rocs-4.14.0.ebuild b/kde-base/rocs/rocs-4.14.0.ebuild
new file mode 100644
index 000000000000..01135812aeb0
--- /dev/null
+++ b/kde-base/rocs/rocs-4.14.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.14.0.ebuild,v 1.1 2014/08/20 16:02:42 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface to work with Graph Theory"
+HOMEPAGE="http://www.kde.org/applications/education/rocs
+http://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/grantlee
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT=test
+# bug 443752
+
+src_test() {
+ local mycmakeargs=(-DKDE4_BUILD_TESTS=ON)
+ cmake-utils_src_configure
+ kde4-base_src_compile
+
+ cd "${BUILD_DIR}"
+ emake DESTDIR="${T}/tests" install
+ export KDEDIRS="${KDEDIRS}:${T}/tests/${PREFIX}"
+ kbuildsycoca4
+ ctest || die "tests failed"
+}