summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
commitaed7569556697316dc345ae4ca172377916e8ab2 (patch)
tree6e2289aa47f31b041e7299a47dc94defaa7729a3 /kde-base/solid
parentKeyword ~ppc64 wrt #337385 (diff)
downloadgentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.tar.gz
gentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.tar.bz2
gentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.zip
KDE SC 4.5.3 Version bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.5.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index 4d8b10605afe..77ca3e8b94a9 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.88 2010/10/06 09:17:21 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.89 2010/11/03 16:30:57 scarabeus Exp $
+
+*solid-4.5.3 (03 Nov 2010)
+
+ 03 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> +solid-4.5.3.ebuild:
+ Version bump
*solid-4.5.2 (05 Oct 2010)
diff --git a/kde-base/solid/solid-4.5.3.ebuild b/kde-base/solid/solid-4.5.3.ebuild
new file mode 100644
index 000000000000..ae28f2c1a71c
--- /dev/null
+++ b/kde-base/solid/solid-4.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.5.3.ebuild,v 1.1 2010/11/03 16:30:57 scarabeus Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug +hal networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep solid-runtime)
+ hal? ( sys-apps/hal )
+"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.69-darwin-compile-powermanager.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}