summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-19 02:24:14 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-19 02:24:14 +0000
commit0e437d2ed6de02862e737645eb9c27c0e10d2d3c (patch)
treeaab4f729b367880e5f606d7a411563e71a9c1790 /kde-misc
parentreadding 12.8, needed as dep for oclhashcat-*-bin (diff)
downloadgentoo-2-0e437d2ed6de02862e737645eb9c27c0e10d2d3c.tar.gz
gentoo-2-0e437d2ed6de02862e737645eb9c27c0e10d2d3c.tar.bz2
gentoo-2-0e437d2ed6de02862e737645eb9c27c0e10d2d3c.zip
Add nls USE flag for gettext dependency. Add kover-6, which builds with newly split libcdio-paranoia, add dependency to kover-5 to specify maximum libcdio, fix dependencies (all wrt bug 452428).
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kover/kover-5.ebuild18
-rw-r--r--kde-misc/kover/kover-6.ebuild28
2 files changed, 37 insertions, 9 deletions
diff --git a/kde-misc/kover/kover-5.ebuild b/kde-misc/kover/kover-5.ebuild
index 610fb4365bdf..2601f4ed5fa2 100644
--- a/kde-misc/kover/kover-5.ebuild
+++ b/kde-misc/kover/kover-5.ebuild
@@ -1,28 +1,28 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kover/kover-5.ebuild,v 1.1 2012/12/10 16:10:30 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kover/kover-5.ebuild,v 1.2 2013/01/19 02:24:14 creffett Exp $
-EAPI=4
+EAPI=5
KDE_LINGUAS="de es fr it nb no pl"
inherit kde4-base
-DESCRIPTION="Kover is an easy to use WYSIWYG CD cover printer with CDDB support"
+DESCRIPTION="An easy to use WYSIWYG CD cover printer with CDDB support"
HOMEPAGE="http://lisas.de/kover/"
SRC_URI="http://lisas.de/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="4"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="nls"
-DEPEND="
- sys-devel/gettext
-"
RDEPEND="
- dev-libs/libcdio
+ <dev-libs/libcdio-0.90[-minimal]
media-libs/libcddb
"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
PATCHES=(
"${FILESDIR}/${PN}-4-cflags.patch"
)
diff --git a/kde-misc/kover/kover-6.ebuild b/kde-misc/kover/kover-6.ebuild
new file mode 100644
index 000000000000..bae1eb926294
--- /dev/null
+++ b/kde-misc/kover/kover-6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kover/kover-6.ebuild,v 1.1 2013/01/19 02:24:14 creffett Exp $
+
+EAPI=5
+KDE_LINGUAS="de es fr it nb no pl"
+
+inherit kde4-base
+
+DESCRIPTION="An easy to use WYSIWYG CD cover printer with CDDB support"
+HOMEPAGE="http://lisas.de/kover/"
+SRC_URI="http://lisas.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ dev-libs/libcdio-paranoia
+ media-libs/libcddb
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-4-cflags.patch"
+)