summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-01 10:59:31 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-01 10:59:31 +0000
commit55b4e884187ddcb563ef24228437682182b15e8d (patch)
treed61f3118b0ac8220c5863cf5c35136e45bc1a224 /kde-misc
parentAdded to ~hppa. See bug #145528. (diff)
downloadgentoo-2-55b4e884187ddcb563ef24228437682182b15e8d.tar.gz
gentoo-2-55b4e884187ddcb563ef24228437682182b15e8d.tar.bz2
gentoo-2-55b4e884187ddcb563ef24228437682182b15e8d.zip
Version bump.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog8
-rw-r--r--kde-misc/tellico/files/digest-tellico-1.23
-rw-r--r--kde-misc/tellico/tellico-1.2.ebuild55
3 files changed, 65 insertions, 1 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index fb8193f82829..1b3ec8e9f5b1 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.42 2006/05/31 15:16:23 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.43 2006/09/01 10:59:31 carlo Exp $
+
+*tellico-1.2 (01 Sep 2006)
+
+ 01 Sep 2006; Carsten Lohrke <carlo@gentoo.org> -tellico-1.1.ebuild,
+ +tellico-1.2.ebuild:
+ Version bump.
31 May 2006; Carsten Lohrke <carlo@gentoo.org> -tellico-0.13.8.ebuild,
-tellico-1.0.1.ebuild, -tellico-1.0.2.ebuild, -tellico-1.1.1.ebuild,
diff --git a/kde-misc/tellico/files/digest-tellico-1.2 b/kde-misc/tellico/files/digest-tellico-1.2
new file mode 100644
index 000000000000..bb1b0c67131f
--- /dev/null
+++ b/kde-misc/tellico/files/digest-tellico-1.2
@@ -0,0 +1,3 @@
+MD5 a7ecc139d820279b0a89d8f594110094 tellico-1.2.tar.gz 4767790
+RMD160 1426d2636df44a80c603f224fb7ba08047e18d54 tellico-1.2.tar.gz 4767790
+SHA256 7030639ff335f3017f678d016e709ed1828d862919ab2e8f87717e303d1ce1aa tellico-1.2.tar.gz 4767790
diff --git a/kde-misc/tellico/tellico-1.2.ebuild b/kde-misc/tellico/tellico-1.2.ebuild
new file mode 100644
index 000000000000..804dc5b2cd9d
--- /dev/null
+++ b/kde-misc/tellico/tellico-1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-1.2.ebuild,v 1.1 2006/09/01 10:59:31 carlo Exp $
+
+inherit kde sgml-catalog
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A collection manager for the KDE environment."
+HOMEPAGE="http://www.periapsis.org/tellico"
+SRC_URI="http://www.periapsis.org/tellico/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="calendar cddb yaz"
+
+DEPEND=">=dev-libs/libxml2-2.4.23
+ >=dev-libs/libxslt-1.0.19
+ cddb? ( || ( kde-base/libkcddb kde-base/kdemultimedia ) )
+ calendar? ( || ( ( kde-base/ktnef kde-base/libkcal ) kde-base/kdepim ) )
+ media-libs/taglib
+ yaz? ( dev-libs/yaz )"
+
+need-kde 3.4
+
+RESTRICT="test"
+
+src_compile() {
+ local myconf="$(use_enable cddb libkcddb) $(use_enable calendar libkcal)"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ einfo "Installing catalog..."
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegatePublic" \
+ "-//Robby Stephenson/DTD Tellico V9.0//EN" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateSystem" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+ ${ROOT}/usr/bin/xmlcatalog --noout --add "delegateURI" \
+ "http://www.periapsis.org/tellico/dtd/v9/tellico.dtd" \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+}
+
+pkg_postrm() {
+ ${ROOT}/usr/bin/xmlcatalog --noout --del \
+ "file://${ROOT}usr/share/apps/tellico/tellico.dtd" \
+ ${ROOT}/etc/xml/catalog
+} \ No newline at end of file