summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-03 09:19:57 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-03 09:19:57 +0000
commitcae6c0f7afc4e88452efccb8fbf3a58df0c0bba4 (patch)
treefd2369a94a4a32d62a0fd295e16bee8d74592717 /lxde-base
parentBump to 20110727 release of SELinux userspace (diff)
downloadgentoo-2-cae6c0f7afc4e88452efccb8fbf3a58df0c0bba4.tar.gz
gentoo-2-cae6c0f7afc4e88452efccb8fbf3a58df0c0bba4.tar.bz2
gentoo-2-cae6c0f7afc4e88452efccb8fbf3a58df0c0bba4.zip
Version bump
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog7
-rw-r--r--lxde-base/lxpanel/lxpanel-0.5.8.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index 3efbc6f25b91..81a2cee0baec 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.31 2011/07/27 16:34:07 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.32 2011/08/03 09:19:57 hwoarang Exp $
+
+*lxpanel-0.5.8 (03 Aug 2011)
+
+ 03 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +lxpanel-0.5.8.ebuild:
+ Version bump
*lxpanel-0.5.7-r1 (27 Jul 2011)
diff --git a/lxde-base/lxpanel/lxpanel-0.5.8.ebuild b/lxde-base/lxpanel/lxpanel-0.5.8.ebuild
new file mode 100644
index 000000000000..06d4b6465316
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.5.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.8.ebuild,v 1.1 2011/08/03 09:19:57 hwoarang Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+alsa"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.1-sandbox.patch
+ epatch "${FILESDIR}"/${PN}-0.5.6-broken-apps.patch
+ eautoreconf
+}
+
+src_configure() {
+ local plugins=all
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins=${plugins}
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+
+ # Get rid of the .la files.
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ elog "If you have problems with broken icons shown in the main panel,"
+ elog "you will have to configure panel settings via its menu."
+ elog "This will not be an issue with first time installations."
+}