summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2006-04-10 17:39:19 +0000
committerTom Martin <slarti@gentoo.org>2006-04-10 17:39:19 +0000
commitec3a20286a73380c584d7024a3d6c73defdcc81e (patch)
tree220d8f9fc7bb2eed2184788e6464728c822abda1 /mail-client/mail-notification
parentrepoman: whitespace cleanup (diff)
downloadgentoo-2-ec3a20286a73380c584d7024a3d6c73defdcc81e.tar.gz
gentoo-2-ec3a20286a73380c584d7024a3d6c73defdcc81e.tar.bz2
gentoo-2-ec3a20286a73380c584d7024a3d6c73defdcc81e.zip
Fix Evolution support, resolving bug #129410; misc. clean-ups.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'mail-client/mail-notification')
-rw-r--r--mail-client/mail-notification/ChangeLog5
-rw-r--r--mail-client/mail-notification/mail-notification-2.0.ebuild19
2 files changed, 17 insertions, 7 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index 3d1ba6659692..84cacd18a96d 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.28 2006/04/08 10:51:45 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.29 2006/04/10 17:39:19 slarti Exp $
+
+ 10 Apr 2006; Tom Martin <slarti@gentoo.org> mail-notification-2.0.ebuild:
+ Fix Evolution support, resolving bug #129410; misc. clean-ups.
08 Apr 2006; Tom Martin <slarti@gentoo.org>
+files/mail-notification-2.0-evolution-2.6.diff,
diff --git a/mail-client/mail-notification/mail-notification-2.0.ebuild b/mail-client/mail-notification/mail-notification-2.0.ebuild
index ee6f4d13f2b1..5672ffbda9fc 100644
--- a/mail-client/mail-notification/mail-notification-2.0.ebuild
+++ b/mail-client/mail-notification/mail-notification-2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-2.0.ebuild,v 1.6 2006/04/08 10:51:45 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-2.0.ebuild,v 1.7 2006/04/10 17:39:19 slarti Exp $
-inherit eutils gnome2 multilib flag-o-matic
+inherit eutils gnome2 multilib flag-o-matic versionator
DESCRIPTION="A GNOME trayicon which checks for mail. Supports mbox, MH,
Maildir, IMAP, Sylpheed, POP3, Gmail and Evolution. Authenticates via
@@ -35,7 +35,9 @@ DEPEND=">=x11-libs/gtk+-2.6
pkg_setup() {
if use evolution ; then
- EVO_VERSION="$(best_version mail-client/evolution)"
+ EVO_INSTALLED="$(best_version mail-client/evolution)"
+ EVO_VERSION=${EVO_INSTALLED##*-}
+ EVO_VERSION=$(get_version_component_range 1-2 ${EVO_VERSION})
fi
G2CONF="${G2CONF} $(use_enable ssl)"
@@ -46,7 +48,7 @@ pkg_setup() {
G2CONF="${G2CONF} $(use_enable pop pop3)"
G2CONF="${G2CONF} $(use_enable gmail)"
G2CONF="${G2CONF} $(use_enable evolution)"
- G2CONF="${G2CONF} --with-evolution-source-dir=/usr/include/${EVO_VERSION}/"
+ G2CONF="${G2CONF} --with-evolution-source-dir=/usr/include/evolution-${EVO_VERSION}"
G2CONF="${G2CONF} $(use_enable sylpheed)"
}
@@ -54,7 +56,10 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch "${FILESDIR}/${P}-evolution-${EVO_VERSION}.diff"
+ if use evolution ; then
+ epatch "${FILESDIR}/${P}-evolution-${EVO_VERSION}.diff"
+ fi
+
epatch "${FILESDIR}/${P}-buildfix.diff"
epatch "${FILESDIR}/${P}-gmail-properties-fix.diff"
@@ -68,7 +73,9 @@ src_compile() {
src_install() {
gnome2_src_install
- evolution_plugindir="/usr/$(get_libdir)/evolution/${EVO_VERSION}/plugins"
+ evolution_plugindir="/usr/$(get_libdir)/evolution/${EVO_INSTALLED}/plugins"
+
+ dodoc README NEWS AUTHORS TODO
}
pkg_postinst() {