summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-01-12 17:15:23 +0000
committerHans de Graaff <graaff@gentoo.org>2008-01-12 17:15:23 +0000
commit16d5f48afbc861ef36178df38ce6fb1b8f4a203c (patch)
tree73bad1f66c0c7fc77aebd5425e70ef24b3acf3b4 /mail-client
parentStable on ppc wrt bug 205434 (diff)
downloadgentoo-2-16d5f48afbc861ef36178df38ce6fb1b8f4a203c.tar.gz
gentoo-2-16d5f48afbc861ef36178df38ce6fb1b8f4a203c.tar.bz2
gentoo-2-16d5f48afbc861ef36178df38ce6fb1b8f4a203c.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/ChangeLog11
-rw-r--r--mail-client/mail-notification/files/digest-mail-notification-5.03
-rw-r--r--mail-client/mail-notification/mail-notification-5.0.ebuild72
3 files changed, 84 insertions, 2 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index 2c937cb7746b..d277986e78c0 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/mail-notification
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.54 2007/12/24 13:49:20 graaff Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.55 2008/01/12 17:15:23 graaff Exp $
+
+*mail-notification-5.0 (12 Jan 2008)
+
+ 12 Jan 2008; Hans de Graaff <graaff@gentoo.org>
+ +mail-notification-5.0.ebuild:
+ Version bump with numerous changes. Also changed license to GPL-3, and cleanup
+ of ebuild now that evolution support is much more straightforward.
24 Dec 2007; Hans de Graaff <graaff@gentoo.org>
-mail-notification-4.0.ebuild, -mail-notification-4.1.ebuild:
diff --git a/mail-client/mail-notification/files/digest-mail-notification-5.0 b/mail-client/mail-notification/files/digest-mail-notification-5.0
new file mode 100644
index 000000000000..56fb779cc05c
--- /dev/null
+++ b/mail-client/mail-notification/files/digest-mail-notification-5.0
@@ -0,0 +1,3 @@
+MD5 66bc819ef62a050627627b3496e4dfe8 mail-notification-5.0.tar.bz2 774039
+RMD160 a24c6a02844ef01c8a8be026a78e4c061c2275f5 mail-notification-5.0.tar.bz2 774039
+SHA256 c991b895da02d5830a37e81ad86f4ff2bf6020a63b75f4cf475c3b7900788258 mail-notification-5.0.tar.bz2 774039
diff --git a/mail-client/mail-notification/mail-notification-5.0.ebuild b/mail-client/mail-notification/mail-notification-5.0.ebuild
new file mode 100644
index 000000000000..fe1504d216a0
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-5.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.0.ebuild,v 1.1 2008/01/12 17:15:23 graaff Exp $
+
+inherit autotools eutils gnome2 multilib flag-o-matic versionator
+
+DESCRIPTION="A GNOME trayicon which checks for email. Supports mbox, MH,
+Maildir, IMAP, Sylpheed, POP3, Gmail and Evolution. Authenticates via
+apop, ssl, sasl."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="imap ipv6 ssl sasl gmail evo sylpheed mbox maildir pop mozilla"
+
+# tests are currently broken and officially not supported upstream:
+# https://bugs.launchpad.net/mail-notification/+bug/182234
+RESTRICT="test"
+
+# gmime is actually optional, but it's used by so much of the package
+# it's pointless making it optional. gnome-keyring is required for
+# several specific access methods, and thus linked to those USE flags
+# instead of adding a keyring USE flag.
+DEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.10
+ >=dev-util/gob-2.0.13
+ >=gnome-base/gnome-panel-2.6
+ >=gnome-base/eel-2.6
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libglade-2.0
+ >=gnome-base/orbit-2.6
+ >=gnome-base/libbonobo-2.0
+ >=dev-libs/gmime-2.1
+ >=x11-libs/libnotify-0.4.1
+ dev-perl/XML-Parser
+ pop? ( gnome-base/gnome-keyring )
+ imap? ( gnome-base/gnome-keyring )
+ gmail? ( gnome-base/gnome-keyring )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ evo? ( >=mail-client/evolution-2.12 )
+ sylpheed? ( virtual/sylpheed )"
+
+DOCS="README NEWS AUTHORS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable ssl)"
+ G2CONF="${G2CONF} $(use_enable sasl)"
+ G2CONF="${G2CONF} $(use_enable ipv6)"
+ # ssl, sasl and ipv6 requires either pop3 or imap, else they will be disabled
+ G2CONF="${G2CONF} $(use_enable imap)"
+ G2CONF="${G2CONF} $(use_enable pop pop3)"
+ G2CONF="${G2CONF} $(use_enable gmail)"
+ G2CONF="${G2CONF} $(use_enable evo evolution)"
+ G2CONF="${G2CONF} $(use_enable sylpheed)"
+ G2CONF="${G2CONF} $(use_enable mozilla)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ sed -i -e 's:gtk-update-icon-cache:true:' ./art/Makefile.in
+}
+
+src_compile() {
+ append-ldflags -Wl,-export-dynamic
+ gnome2_src_compile
+}