summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2006-07-14 14:05:31 +0000
committerAkinori Hattori <hattya@gentoo.org>2006-07-14 14:05:31 +0000
commitab119645eb2a1d606f1ab54d56a4653fd2d80c4c (patch)
tree3f8524f35bd62486d621c049a677fb489c105ba5 /mail-client
parentAdded missing USE: source. (diff)
downloadgentoo-2-ab119645eb2a1d606f1ab54d56a4653fd2d80c4c.tar.gz
gentoo-2-ab119645eb2a1d606f1ab54d56a4653fd2d80c4c.tar.bz2
gentoo-2-ab119645eb2a1d606f1ab54d56a4653fd2d80c4c.zip
new upstream release.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.2.63
-rw-r--r--mail-client/sylpheed/sylpheed-2.2.6.ebuild70
3 files changed, 79 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index d9c0adf87b2b..73957c010afe 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.183 2006/06/10 18:02:18 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.184 2006/07/14 14:05:31 hattya Exp $
+
+*sylpheed-2.2.6 (14 Jul 2006)
+
+ 14 Jul 2006; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.2.6.ebuild:
+ new upstream release.
10 Jun 2006; Guy Martin <gmsoft@gentoo.org> sylpheed-2.2.5.ebuild:
Stable on hppa.
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.2.6 b/mail-client/sylpheed/files/digest-sylpheed-2.2.6
new file mode 100644
index 000000000000..69fbff170b32
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.2.6
@@ -0,0 +1,3 @@
+MD5 ecd880cce22a2755bcf05503a0ed7bbf sylpheed-2.2.6.tar.bz2 2537355
+RMD160 020045ee924cc7a4aea26ca6bc558945a4b20c83 sylpheed-2.2.6.tar.bz2 2537355
+SHA256 f3c1ac37e293c1dc969ac14aff650532e52a2d9c105ed86ad2a858f1254ed70b sylpheed-2.2.6.tar.bz2 2537355
diff --git a/mail-client/sylpheed/sylpheed-2.2.6.ebuild b/mail-client/sylpheed/sylpheed-2.2.6.ebuild
new file mode 100644
index 000000000000..994c5f974156
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.2.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.2.6.ebuild,v 1.1 2006/07/14 14:05:31 hattya Exp $
+
+inherit autotools eutils
+
+IUSE="crypt gnome ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.good-day.net/"
+SRC_URI="http://sylpheed.good-day.net/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+ eautomake
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable crypt gpgme` \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_enable nls` \
+ `use_enable pda jpilot` \
+ `use_enable spell gtkspell` \
+ `use_enable ssl` \
+ `use_enable xface compface` \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ insinto /usr/share/applications
+ doins sylpheed.desktop
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+}