summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-02-28 11:01:55 +0000
committerRoy Marples <uberlord@gentoo.org>2007-02-28 11:01:55 +0000
commit5ffd86a4a3d97ce30a8fcb9658c2c7cbe66df4f5 (patch)
tree407e6d8a97cd5ae2131ea3f2ccbd4a682c5d1459 /mail-filter/bogofilter
parentEbuild cleanup and mark stable on amd64. (diff)
downloadgentoo-2-5ffd86a4a3d97ce30a8fcb9658c2c7cbe66df4f5.tar.gz
gentoo-2-5ffd86a4a3d97ce30a8fcb9658c2c7cbe66df4f5.tar.bz2
gentoo-2-5ffd86a4a3d97ce30a8fcb9658c2c7cbe66df4f5.zip
Added ~x86-fbsd keyword. When building against berkdb, include the versioned
db header dir as /usr/include/db.h is always db-1 on FreeBSD. (Portage version: 2.1.2-r12)
Diffstat (limited to 'mail-filter/bogofilter')
-rw-r--r--mail-filter/bogofilter/ChangeLog6
-rw-r--r--mail-filter/bogofilter/bogofilter-1.1.5.ebuild15
2 files changed, 17 insertions, 4 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index f8a3fcd6231b..1abd90143e7f 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.82 2007/01/15 07:25:49 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.83 2007/02/28 11:01:55 uberlord Exp $
+
+ 28 Feb 2007; Roy Marples <uberlord@gentoo.org> bogofilter-1.1.5.ebuild:
+ Added ~x86-fbsd keyword. When building against berkdb, include the versioned
+ db header dir as /usr/include/db.h is always db-1 on FreeBSD.
*bogofilter-1.1.5 (15 Jan 2007)
diff --git a/mail-filter/bogofilter/bogofilter-1.1.5.ebuild b/mail-filter/bogofilter/bogofilter-1.1.5.ebuild
index 3d5ab16b9069..65c280336b17 100644
--- a/mail-filter/bogofilter/bogofilter-1.1.5.ebuild
+++ b/mail-filter/bogofilter/bogofilter-1.1.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.5.ebuild,v 1.2 2007/02/11 10:26:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.5.ebuild,v 1.3 2007/02/28 11:01:55 uberlord Exp $
+
+inherit db-use flag-o-matic
DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
HOMEPAGE="http://bogofilter.sourceforge.net/"
@@ -8,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="gsl berkdb sqlite"
DEPEND="virtual/libiconv
@@ -20,18 +22,25 @@ DEPEND="virtual/libiconv
# app-arch/pax" # only needed for bf_tar
src_compile() {
- local myconf=""
+ local myconf="" berkdb=false
myconf="$(use_with !gsl included-gsl)"
# determine backend: berkdb *is* default
if use berkdb && use sqlite ; then
elog "Both useflags berkdb and sqlite are in USE:"
elog "Using berkdb as database backend."
+ berkdb=true
elif use sqlite ; then
myconf="${myconf} --with-database=sqlite"
elif ! use berkdb ; then
elog "Neither berkdb nor sqlite are in USE:"
elog "Using berkdb as database backend."
+ berkdb=true
+ fi
+
+ # Include the right berkdb headers for FreeBSD
+ if ${berkdb} ; then
+ append-flags "-I$(db_includedir)"
fi
econf ${myconf} || die "configure failed"