summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-10-09 14:45:12 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-10-09 14:45:12 +0000
commit44003e2f70d7e9a3abfdd533865d661ff9e8a9b4 (patch)
treed995e231f903398b3abe87365bf86e91d2d370d6 /mail-filter
parentAdded sparc stable keyword (Manifest recommit) (diff)
downloadgentoo-2-44003e2f70d7e9a3abfdd533865d661ff9e8a9b4.tar.gz
gentoo-2-44003e2f70d7e9a3abfdd533865d661ff9e8a9b4.tar.bz2
gentoo-2-44003e2f70d7e9a3abfdd533865d661ff9e8a9b4.zip
Added the UntrustedMailerArgs
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/dspam/ChangeLog5
-rw-r--r--mail-filter/dspam/dspam-3.2_rc2.ebuild15
2 files changed, 14 insertions, 6 deletions
diff --git a/mail-filter/dspam/ChangeLog b/mail-filter/dspam/ChangeLog
index ec37197c04b7..5346e7db7cc6 100644
--- a/mail-filter/dspam/ChangeLog
+++ b/mail-filter/dspam/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-filter/dspam
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.17 2004/10/09 04:40:13 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.18 2004/10/09 14:45:12 st_lim Exp $
+
+ 09 Oct 2004; Lim Swee Tat <st_lim@gentoo.org> dspam-3.2_rc2.ebuild:
+ Changed the UntrustedMailerArgs
*dspam-3.2_rc2 (09 Oct 2004)
diff --git a/mail-filter/dspam/dspam-3.2_rc2.ebuild b/mail-filter/dspam/dspam-3.2_rc2.ebuild
index 53d4689766b3..a6837befa428 100644
--- a/mail-filter/dspam/dspam-3.2_rc2.ebuild
+++ b/mail-filter/dspam/dspam-3.2_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2_rc2.ebuild,v 1.1 2004/10/09 04:40:13 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2_rc2.ebuild,v 1.2 2004/10/09 14:45:12 st_lim Exp $
inherit eutils
@@ -181,13 +181,18 @@ src_install () {
echo "enableWhitelist=on") >${T}/default.prefs
echo "groupname:classification:*globaluser" >${T}/group
if use cyrus; then
- echo "/usr/lib/cyrus/deliver %u" > ${T}/untrusted.mailer_args
+ echo "UntrustedDeliveryAgent /usr/lib/cyrus/deliver %u" >> ${D}${HOMEDIR}/dspam.conf
+ sed -e 's:/usr/bin/procmail:/usr/lib/cyrus/deliver %u:g' \
+ -i ${D}${HOMEDIR}/dspam.conf
elif use exim; then
- echo "/usr/sbin/exim -oMr spam-scanned %u" > ${T}/untrusted.mailer_args
+ echo "UntrustedDeliveryAgent /usr/sbin/exim -oMr spam-scanned %u" >> ${D}${HOMEDIR}/dspam.conf
+ sed -e 's:/usr/bin/procmail:/usr/sbin/exim -oMr spam-scanned %u:g' \
+ -i ${D}${HOMEDIR}/dspam.conf
elif use courier; then
echo "/usr/bin/maildrop -d %u" > ${T}/untrusted.mailer_args
- elif use procmail; then
- echo "/usr/bin/procmail -d %u" > ${T}/untrusted.mailer_args
+ echo "UntrustedDeliveryAgent /usr/bin/maildrop -d %u" >> ${D}${HOMEDIR}/dspam.conf
+ sed -e 's:/usr/bin/procmail:/usr/bin/maildrop -d %u:g' \
+ -i ${D}${HOMEDIR}/dspam.conf
fi
# install some initial configuration