summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-01-15 07:25:49 +0000
committerTorsten Veller <tove@gentoo.org>2007-01-15 07:25:49 +0000
commit4bf3f4738384328f91aa95fedc5f776a84e5868e (patch)
tree5b910d5f4b4bb3e3e4a83edda6c41e29600b8f60 /mail-filter
parentMarked stable on x86 for Ticho (#155782) (diff)
downloadgentoo-2-4bf3f4738384328f91aa95fedc5f776a84e5868e.tar.gz
gentoo-2-4bf3f4738384328f91aa95fedc5f776a84e5868e.tar.bz2
gentoo-2-4bf3f4738384328f91aa95fedc5f776a84e5868e.zip
Version bump.
(Portage version: 2.1.2)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog8
-rw-r--r--mail-filter/bogofilter/bogofilter-1.1.5.ebuild69
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-1.1.53
3 files changed, 79 insertions, 1 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 015d2b967a9b..f8a3fcd6231b 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.81 2007/01/06 21:10:48 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.82 2007/01/15 07:25:49 tove Exp $
+
+*bogofilter-1.1.5 (15 Jan 2007)
+
+ 15 Jan 2007; Torsten Veller <tove@gentoo.org> -bogofilter-1.1.4.ebuild,
+ +bogofilter-1.1.5.ebuild:
+ Version bump. Removed 1.1.4
06 Jan 2007; Torsten Veller <tove@gentoo.org>
-files/1.1.3-patch.1142.Makefile.in, bogofilter-0.92.8.ebuild,
diff --git a/mail-filter/bogofilter/bogofilter-1.1.5.ebuild b/mail-filter/bogofilter/bogofilter-1.1.5.ebuild
new file mode 100644
index 000000000000..feaf05b72b6f
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.1.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.5.ebuild,v 1.1 2007/01/15 07:25:49 tove Exp $
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gsl berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ elog "Both useflags berkdb and sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! use berkdb ; then
+ elog "Neither berkdb nor sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ echo
+ elog "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ echo
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-1.1.5 b/mail-filter/bogofilter/files/digest-bogofilter-1.1.5
new file mode 100644
index 000000000000..948a3f83dde5
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-1.1.5
@@ -0,0 +1,3 @@
+MD5 d524be9e9c43d9dbb593d7a3c4564f5d bogofilter-1.1.5.tar.bz2 798031
+RMD160 8f00f0e6660571c2d5cacc2eaf117bd6f95fc6ce bogofilter-1.1.5.tar.bz2 798031
+SHA256 de62774ccb74df65a16a67e141fca7370243c1a8b96131f77339265ce9002a00 bogofilter-1.1.5.tar.bz2 798031