summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 20:17:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 20:17:38 +0000
commitc3851597c04c7d4ac01f0387313ddbebd1cbcd22 (patch)
treec6bba0cdfff2e42893c96f7d239e204c315d381d /mail-filter
parentVersion bump. Fixes bug #350855 reported by Nickolaj Stjujsckij. (diff)
downloadgentoo-2-c3851597c04c7d4ac01f0387313ddbebd1cbcd22.tar.gz
gentoo-2-c3851597c04c7d4ac01f0387313ddbebd1cbcd22.tar.bz2
gentoo-2-c3851597c04c7d4ac01f0387313ddbebd1cbcd22.zip
Remove old version and fix build with berkdb 5.0 (bug #319941).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamprobe/ChangeLog9
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4b-gcc41.patch12
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch13
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4b.ebuild35
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d.ebuild7
5 files changed, 24 insertions, 52 deletions
diff --git a/mail-filter/spamprobe/ChangeLog b/mail-filter/spamprobe/ChangeLog
index e673ad0bf25b..8c7441762b3e 100644
--- a/mail-filter/spamprobe/ChangeLog
+++ b/mail-filter/spamprobe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/spamprobe
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.26 2010/03/08 17:34:40 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/ChangeLog,v 1.27 2011/01/10 20:17:37 flameeyes Exp $
+
+ 10 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> -spamprobe-1.4b.ebuild,
+ -files/spamprobe-1.4b-gcc41.patch, spamprobe-1.4d.ebuild,
+ +files/spamprobe-1.4d+db-5.0.patch:
+ Remove old version and fix build with berkdb 5.0 (bug #319941).
08 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> spamprobe-1.4d.ebuild,
+files/spamprobe-1.4d-libpng14.patch:
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4b-gcc41.patch b/mail-filter/spamprobe/files/spamprobe-1.4b-gcc41.patch
deleted file mode 100644
index b5c7225215f1..000000000000
--- a/mail-filter/spamprobe/files/spamprobe-1.4b-gcc41.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur spamprobe-1.4b-orig/src/includes/Buffer.h spamprobe-1.4b/src/includes/Buffer.h
---- spamprobe-1.4b-orig/src/includes/Buffer.h 2006-03-10 20:42:01.000000000 -0500
-+++ spamprobe-1.4b/src/includes/Buffer.h 2006-03-10 20:42:38.000000000 -0500
-@@ -32,6 +32,7 @@
- #define _Buffer_h
-
- #include "Array.h"
-+#include <cassert>
-
- //
- // Similar to Array but handles variable length.
-
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch b/mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch
new file mode 100644
index 000000000000..5ea5db04fff1
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch
@@ -0,0 +1,13 @@
+Index: spamprobe-1.4d/src/database/FrequencyDBImpl_bdb.cc
+===================================================================
+--- spamprobe-1.4d.orig/src/database/FrequencyDBImpl_bdb.cc
++++ spamprobe-1.4d/src/database/FrequencyDBImpl_bdb.cc
+@@ -155,7 +155,7 @@ bool FrequencyDBImpl_bdb::openDatabase(c
+ // hideous ifdefs into my code.
+ string filename(m_env ? db_file.getName() : db_file.getPath());
+ int flags = read_only ? DB_RDONLY : DB_CREATE;
+-#if DB_VERSION_MAJOR >= 4 && DB_VERSION_MINOR >= 1
++#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || DB_VERSION_MAJOR >= 5
+ ret = m_file->open(m_file, NULL, filename.c_str(), NULL, DB_BTREE, flags, create_mode);
+ #else
+ ret = m_file->open(m_file, filename.c_str(), NULL, DB_BTREE, flags, create_mode);
diff --git a/mail-filter/spamprobe/spamprobe-1.4b.ebuild b/mail-filter/spamprobe/spamprobe-1.4b.ebuild
deleted file mode 100644
index e599a2b48a71..000000000000
--- a/mail-filter/spamprobe/spamprobe-1.4b.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-1.4b.ebuild,v 1.5 2008/04/28 16:44:38 ticho Exp $
-
-inherit eutils
-
-DESCRIPTION="Fast, intelligent, automatic spam detector using Bayesian analysis."
-HOMEPAGE="http://spamprobe.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="QPL"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-
-IUSE="berkdb"
-DEPEND="berkdb? ( >=sys-libs/db-3.2 )"
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}"/${P}-gcc41.patch
-}
-
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dodoc README.txt ChangeLog LICENSE.txt
- make DESTDIR="${D}" install || die
-
- insinto /usr/share/${PN}/contrib
- doins contrib/*
-}
diff --git a/mail-filter/spamprobe/spamprobe-1.4d.ebuild b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
index cbeb98c17d81..80a33b0fe524 100644
--- a/mail-filter/spamprobe/spamprobe-1.4d.ebuild
+++ b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-1.4d.ebuild,v 1.5 2010/03/08 17:34:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamprobe/spamprobe-1.4d.ebuild,v 1.6 2011/01/10 20:17:37 flameeyes Exp $
EAPI=2
inherit eutils
@@ -21,7 +21,8 @@ DEPEND="berkdb? ( >=sys-libs/db-3.2 )
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.4b-gcc43.patch \
- "${FILESDIR}"/${P}-libpng14.patch
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}+db-5.0.patch
}
src_configure() {