summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-08 05:36:36 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-08 05:36:36 +0000
commitcb8596d6ad9676d2389b668189f058e17df7ea43 (patch)
tree22de8ddfc1e9857eb0674e307829643b019c7597 /mail-filter
parenttouchups (Manifest recommit) (diff)
downloadgentoo-2-cb8596d6ad9676d2389b668189f058e17df7ea43.tar.gz
gentoo-2-cb8596d6ad9676d2389b668189f058e17df7ea43.tar.bz2
gentoo-2-cb8596d6ad9676d2389b668189f058e17df7ea43.zip
move to hppa stable and remove crap from global scope
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/spamassassin-2.64.ebuild33
1 files changed, 15 insertions, 18 deletions
diff --git a/mail-filter/spamassassin/spamassassin-2.64.ebuild b/mail-filter/spamassassin/spamassassin-2.64.ebuild
index 8d3bc645a63b..2efc8509dba6 100644
--- a/mail-filter/spamassassin/spamassassin-2.64.ebuild
+++ b/mail-filter/spamassassin/spamassassin-2.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/spamassassin-2.64.ebuild,v 1.5 2004/08/07 19:05:16 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/spamassassin/spamassassin-2.64.ebuild,v 1.6 2004/08/08 05:36:36 vapier Exp $
inherit perl-module
@@ -13,7 +13,7 @@ SRC_URI="http://old.spamassassin.org/released/${MY_P}.tar.bz2"
LICENSE="GPL-2 | Artistic"
SLOT="0"
-KEYWORDS="~x86 ppc sparc alpha ~hppa ~mips ia64 amd64 ~ppc64"
+KEYWORDS="~x86 ppc sparc ~mips alpha hppa amd64 ia64 ~ppc64"
IUSE="berkdb ssl"
DEPEND="|| ( >=dev-lang/perl-5.8.2-r1
@@ -29,22 +29,6 @@ DEPEND="|| ( >=dev-lang/perl-5.8.2-r1
ssl? ( dev-perl/IO-Socket-SSL )
berkdb? ( dev-perl/DB_File )"
-# If ssl is enabled, spamc can be built with ssl support
-if use ssl; then
- myconf="${myconf} ENABLE_SSL=yes"
-fi
-
-# if you are going to enable taint mode, make sure that the bug where
-# spamd doesn't start when the PATH contains . is addressed, and make
-# sure you deal with versions of razor <2.36-r1 not being taint-safe.
-# <http://bugzilla.spamassassin.org/show_bug.cgi?id=2511> and
-# <http://spamassassin.org/released/Razor2.patch>.
-
-myconf="${myconf} PERL_TAINT=no"
-
-# No settings needed for 'make all'.
-mymake=""
-
# Neither for 'make install'.
myinst=""
@@ -62,6 +46,19 @@ mydoc="License
qmail/README.qmail-spamc"
src_compile() {
+ # If ssl is enabled, spamc can be built with ssl support
+ use ssl && myconf="${myconf} ENABLE_SSL=yes"
+
+ # if you are going to enable taint mode, make sure that the bug where
+ # spamd doesn't start when the PATH contains . is addressed, and make
+ # sure you deal with versions of razor <2.36-r1 not being taint-safe.
+ # <http://bugzilla.spamassassin.org/show_bug.cgi?id=2511> and
+ # <http://spamassassin.org/released/Razor2.patch>.
+ myconf="${myconf} PERL_TAINT=no"
+
+ # No settings needed for 'make all'.
+ mymake=""
+
export PERL_MM_USE_DEFAULT=1
perl-module_src_compile