summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2006-12-20 18:07:14 +0000
committerTom Martin <slarti@gentoo.org>2006-12-20 18:07:14 +0000
commitfe1388d6cbb66bbf631acf9e17e75133bd71b986 (patch)
tree153724b0ae6a87d5cecfc7edc357dfc5c27877b0 /mail-mta/msmtp/msmtp-1.4.9-r1.ebuild
parentTrailing whitespace. (diff)
downloadgentoo-2-fe1388d6cbb66bbf631acf9e17e75133bd71b986.tar.gz
gentoo-2-fe1388d6cbb66bbf631acf9e17e75133bd71b986.tar.bz2
gentoo-2-fe1388d6cbb66bbf631acf9e17e75133bd71b986.zip
Version bump, remove the old mailer.eclass version. Stabilise 1.4.7 on amd64.
(Portage version: 2.1.2_rc3-r8)
Diffstat (limited to 'mail-mta/msmtp/msmtp-1.4.9-r1.ebuild')
-rw-r--r--mail-mta/msmtp/msmtp-1.4.9-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/mail-mta/msmtp/msmtp-1.4.9-r1.ebuild b/mail-mta/msmtp/msmtp-1.4.9-r1.ebuild
new file mode 100644
index 000000000000..2126959e93f4
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.4.9-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.9-r1.ebuild,v 1.1 2006/12/20 18:07:14 slarti Exp $
+
+inherit mailer
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/msmtp/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl gnutls sasl doc nls"
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ sasl? ( >=virtual/gsasl-0.2.4 )
+ nls? ( sys-devel/gettext )"
+
+src_compile () {
+ local myconf
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=gnutls"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=openssl"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf \
+ $(use_enable sasl gsasl) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install failed"
+
+ if use mailwrapper ; then
+ mailer_install_conf
+ else
+ dodir /usr/sbin
+ dosym /usr/bin/msmtp /usr/sbin/sendmail || die "dosym failed"
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS \
+ doc/{Mutt+msmtp.txt,msmtprc*} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/msmtp.html || die "dohtml failed"
+ dodoc doc/msmtp.pdf
+ fi
+}