summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-25 10:16:59 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-25 10:16:59 +0000
commit8219d7ba3ead1f954b8f1663cf604725ef8fe22a (patch)
treea9f0fbb1cd2c85b65581910e74477252922b08b8 /mail-mta
parentVersion bump. (diff)
downloadgentoo-2-8219d7ba3ead1f954b8f1663cf604725ef8fe22a.tar.gz
gentoo-2-8219d7ba3ead1f954b8f1663cf604725ef8fe22a.tar.bz2
gentoo-2-8219d7ba3ead1f954b8f1663cf604725ef8fe22a.zip
mail-mta/nullmailer: Drop old vulnerable versions, #480376; respect AR, #480394; make paludis happy, #462846 thanks Thomas Witt for the patch; fix broken openrc initscript, #480354
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/nullmailer/ChangeLog13
-rwxr-xr-xmail-mta/nullmailer/files/init.d-nullmailer-r350
-rw-r--r--mail-mta/nullmailer/nullmailer-1.11-r1.ebuild125
-rw-r--r--mail-mta/nullmailer/nullmailer-1.11-r2.ebuild5
-rw-r--r--mail-mta/nullmailer/nullmailer-1.11-r3.ebuild19
-rw-r--r--mail-mta/nullmailer/nullmailer-1.11.ebuild123
-rw-r--r--mail-mta/nullmailer/nullmailer-1.13-r2.ebuild (renamed from mail-mta/nullmailer/nullmailer-1.13-r1.ebuild)53
-rw-r--r--mail-mta/nullmailer/nullmailer-1.13.ebuild130
8 files changed, 116 insertions, 402 deletions
diff --git a/mail-mta/nullmailer/ChangeLog b/mail-mta/nullmailer/ChangeLog
index d8c6adf15b34..1c01649d7f6f 100644
--- a/mail-mta/nullmailer/ChangeLog
+++ b/mail-mta/nullmailer/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for mail-mta/nullmailer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.73 2013/09/25 08:14:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.74 2013/09/25 10:16:58 jlec Exp $
+
+*nullmailer-1.13-r2 (25 Sep 2013)
+
+ 25 Sep 2013; Justin Lecher <jlec@gentoo.org> -nullmailer-1.11.ebuild,
+ -nullmailer-1.11-r1.ebuild, nullmailer-1.11-r2.ebuild,
+ nullmailer-1.11-r3.ebuild, -nullmailer-1.13.ebuild,
+ -nullmailer-1.13-r1.ebuild, +nullmailer-1.13-r2.ebuild,
+ +files/init.d-nullmailer-r3:
+ Drop old vulnerable versions, #480376; respect AR, #480394; make paludis
+ happy, #462846 thanks Thomas Witt for the patch; fix broken openrc
+ initscript, #480354
25 Sep 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add myself as maintainer
diff --git a/mail-mta/nullmailer/files/init.d-nullmailer-r3 b/mail-mta/nullmailer/files/init.d-nullmailer-r3
new file mode 100755
index 000000000000..f55ef1fe6c06
--- /dev/null
+++ b/mail-mta/nullmailer/files/init.d-nullmailer-r3
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/files/init.d-nullmailer-r3,v 1.1 2013/09/25 10:16:59 jlec Exp $
+
+command="/usr/sbin/nullmailer-send"
+
+start_stop_daemon_args="--chdir /var/nullmailer --user nullmail:nullmail"
+
+required_dirs="/var/nullmailer"
+pidfile="/run/nullmailer.pid"
+command_background="true"
+
+depend() {
+ use net logger
+}
+
+checkconfig() {
+ local error=0
+ local f=/etc/nullmailer/me
+ if [ ! -s ${f} ]; then
+ eerror "${f} does not exist"
+ error=1
+ fi
+ f=/etc/nullmailer/defaultdomain
+ if [ ! -s ${f} ]; then
+ eerror "${f} does not exist"
+ error=1
+ fi
+ if [ ${error} -eq 1 ]; then
+ einfo "You need to run 'emerge --config nullmailer'!"
+ fi
+ if [ -e /service/nullmailer ]; then
+ eerror "Nullmailer is already running under svscan!"
+ error=2
+ fi
+ if [ ${error} -ne 0 ]; then
+ return 1
+ else
+ return 0
+ fi
+}
+
+start_pre() {
+ checkconfig
+}
+
+stop_pre() {
+ checkconfig # to avoid init.d stopping svscan instance
+}
diff --git a/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild b/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild
deleted file mode 100644
index 6983fcb300c5..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11-r1.ebuild,v 1.5 2013/02/28 17:52:54 zx2c4 Exp $
-
-EAPI=4
-WANT_AUTOMAKE="1.10.3"
-inherit eutils flag-o-matic autotools user multilib
-
-MY_P="${P/_rc/RC}"
-S=${WORKDIR}/${MY_P}
-DEBIAN_PV=1.11
-DEBIAN_PR="1"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
-DESCRIPTION="Simple relay-only local mail transport agent"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
- mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-
-IUSE="ssl"
-
-DEPEND="sys-apps/groff
- ssl? ( net-libs/gnutls )"
-RDEPEND="virtual/shadow
- virtual/logger
- ssl? ( net-libs/gnutls )
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/opensmtpd
- !mail-mta/ssmtp"
-
-src_prepare() {
- sed -i -e 's/nullmailer-1.10/nullmailer-1.11/g' \
- "${WORKDIR}"/debian/patches/*.diff || die
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${DISTDIR}"/${DEBIAN_SRC}
- # why revert? Ask Robin when he is back!
- EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
- epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_configure() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf \
- --localstatedir=/var \
- $(use_enable ssl tls)
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.11 remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usability
- dodir /usr/$(get_libdir)
- dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer-r2 nullmailer
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- fi
- #echo
- #elog "To start nullmailer at boot you may use either the nullmailer init.d"
- #elog "script, or emerge sys-process/supervise-scripts, enable the"
- #elog "svscan init.d script and create the following link:"
- #elog "ln -fs /var/nullmailer/service /service/nullmailer"
- #echo
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}
diff --git a/mail-mta/nullmailer/nullmailer-1.11-r2.ebuild b/mail-mta/nullmailer/nullmailer-1.11-r2.ebuild
index 28e00bbf11c9..60e4a1eebf8e 100644
--- a/mail-mta/nullmailer/nullmailer-1.11-r2.ebuild
+++ b/mail-mta/nullmailer/nullmailer-1.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11-r2.ebuild,v 1.4 2013/08/28 12:10:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11-r2.ebuild,v 1.5 2013/09/25 10:16:58 jlec Exp $
EAPI=4
WANT_AUTOMAKE="1.10.3"
@@ -53,6 +53,9 @@ src_prepare() {
sed -i.orig \
-e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
"${S}"/src/Makefile.am || die "Sed failed"
+ sed \
+ -e "s:^AC_PROG_RANLIB:AC_CHECK_TOOL(AR, ar, false)\nAC_PROG_RANLIB:g" \
+ -i configure.in || die
eautoreconf
}
diff --git a/mail-mta/nullmailer/nullmailer-1.11-r3.ebuild b/mail-mta/nullmailer/nullmailer-1.11-r3.ebuild
index 331416b276bf..8fad494ff650 100644
--- a/mail-mta/nullmailer/nullmailer-1.11-r3.ebuild
+++ b/mail-mta/nullmailer/nullmailer-1.11-r3.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11-r3.ebuild,v 1.1 2013/09/08 11:05:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11-r3.ebuild,v 1.2 2013/09/25 10:16:58 jlec Exp $
EAPI=4
+
WANT_AUTOMAKE="1.10.3"
+
inherit eutils flag-o-matic autotools user multilib systemd
MY_P="${P/_rc/RC}"
@@ -41,6 +43,11 @@ RDEPEND="virtual/shadow
!mail-mta/opensmtpd
!mail-mta/ssmtp"
+pkg_setup() {
+ enewgroup nullmail 88
+ enewuser nullmail 88 -1 /var/nullmailer nullmail
+}
+
src_prepare() {
sed -i -e 's/nullmailer-1.10/nullmailer-1.11/g' \
"${WORKDIR}"/debian/patches/*.diff || die
@@ -53,12 +60,12 @@ src_prepare() {
sed -i.orig \
-e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
"${S}"/src/Makefile.am || die "Sed failed"
- eautoreconf
-}
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
+ sed \
+ -e "s:^AC_PROG_RANLIB:AC_CHECK_TOOL(AR, ar, false)\nAC_PROG_RANLIB:g" \
+ -i configure.in || die
+
+ eautoreconf
}
src_configure() {
diff --git a/mail-mta/nullmailer/nullmailer-1.11.ebuild b/mail-mta/nullmailer/nullmailer-1.11.ebuild
deleted file mode 100644
index 89477de3f8ea..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.11.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.11.ebuild,v 1.7 2013/02/28 17:52:54 zx2c4 Exp $
-
-EAPI=4
-WANT_AUTOMAKE="1.10.3"
-inherit eutils flag-o-matic autotools user multilib
-
-MY_P="${P/_rc/RC}"
-S=${WORKDIR}/${MY_P}
-DEBIAN_PV=1.11
-DEBIAN_PR="1"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
-DESCRIPTION="Simple relay-only local mail transport agent"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
- mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-
-IUSE="ssl"
-
-DEPEND="sys-apps/groff
- ssl? ( net-libs/gnutls )"
-RDEPEND="virtual/shadow
- virtual/logger
- ssl? ( net-libs/gnutls )
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/opensmtpd
- !mail-mta/ssmtp"
-
-src_prepare() {
- sed -i -e 's/nullmailer-1.10/nullmailer-1.11/g' \
- "${WORKDIR}"/debian/patches/*.diff || die
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${DISTDIR}"/${DEBIAN_SRC}
- # why revert? Ask Robin when he is back!
- EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
- epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_configure() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf \
- --localstatedir=/var \
- $(use_enable ssl tls)
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.04 remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usablity
- dodir /usr/$(get_libdir)
- dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer-r1 nullmailer
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- echo
- elog "To start nullmailer at boot you may use either the nullmailer init.d"
- elog "script, or emerge sys-process/supervise-scripts, enable the"
- elog "svscan init.d script and create the following link:"
- elog "ln -fs /var/nullmailer/service /service/nullmailer"
- echo
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}
diff --git a/mail-mta/nullmailer/nullmailer-1.13-r1.ebuild b/mail-mta/nullmailer/nullmailer-1.13-r2.ebuild
index f6562660eb11..fef08af7079c 100644
--- a/mail-mta/nullmailer/nullmailer-1.13-r1.ebuild
+++ b/mail-mta/nullmailer/nullmailer-1.13-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.13-r1.ebuild,v 1.2 2013/08/09 16:45:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.13-r2.ebuild,v 1.1 2013/09/25 10:16:58 jlec Exp $
EAPI=5
@@ -45,6 +45,11 @@ RDEPEND="
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ enewgroup nullmail 88
+ enewuser nullmail 88 -1 /var/nullmailer nullmail
+}
+
src_prepare() {
# sed -i -e 's/nullmailer-1.10/nullmailer-1.11/g' \
# "${WORKDIR}"/debian/patches/*.diff || die
@@ -57,14 +62,15 @@ src_prepare() {
sed -i.orig \
-e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
"${S}"/src/Makefile.am || die "Sed failed"
+ sed -i.orig \
+ -e '/\$(localstatedir)\/trigger/d' \
+ "${S}"/Makefile.am || die "Sed failed"
+ sed \
+ -e "s:^AC_PROG_RANLIB:AC_CHECK_TOOL(AR, ar, false)\nAC_PROG_RANLIB:g" \
+ -i configure.in || die
eautoreconf
}
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
src_configure() {
# Note that we pass a different directory below due to bugs in the makefile!
econf \
@@ -74,44 +80,53 @@ src_configure() {
src_install () {
einstall localstatedir="${D}"/var/nullmailer
+
dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
+
# A small bit of sample config
insinto /etc/nullmailer
newins "${FILESDIR}"/remotes.sample-${PV} remotes
+
# This contains passwords, so should be secure
fperms 0640 /etc/nullmailer/remotes
fowners root:nullmail /etc/nullmailer/remotes
+
# daemontools stuff
dodir /var/nullmailer/service{,/log}
+
insinto /var/nullmailer/service
newins scripts/nullmailer.run run
fperms 700 /var/nullmailer/service/run
+
insinto /var/nullmailer/service/log
newins scripts/nullmailer-log.run run
fperms 700 /var/nullmailer/service/log/run
+
# usability
- dodir /usr/$(get_libdir)
dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
+
# permissions stuff
keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer-r2 nullmailer
+
+ newinitd "${FILESDIR}"/init.d-nullmailer-r3 nullmailer
systemd_dounit "${FILESDIR}"/${PN}.service
}
pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
+ if [ ! -e "${ROOT}"/var/nullmailer/trigger ]; then
+ mkfifo "${ROOT}"/var/nullmailer/trigger
+ fi
+ chown nullmail:nullmail \
+ "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger} || die
+ chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue} || die
+ chmod 660 "${ROOT}"/var/nullmailer/trigger || die
# This contains passwords, so should be secure
- chmod 0640 /etc/nullmailer/remotes
- chown root:nullmail /etc/nullmailer/remotes
+ chmod 0640 /etc/nullmailer/remotes || die
+ chown root:nullmail /etc/nullmailer/remotes || die
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To create an initial setup, please do:"
@@ -125,6 +140,12 @@ pkg_postinst() {
#echo
}
+pkg_postrm() {
+ if [[ -e "${ROOT}"/var/nullmailer/trigger ]]; then
+ rm "${ROOT}"/var/nullmailer/trigger || die
+ fi
+}
+
pkg_config() {
if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
einfo "Setting /etc/nullmailer/me"
diff --git a/mail-mta/nullmailer/nullmailer-1.13.ebuild b/mail-mta/nullmailer/nullmailer-1.13.ebuild
deleted file mode 100644
index 63b6ad766968..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.13.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.13.ebuild,v 1.1 2013/07/25 19:10:34 jlec Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic multilib systemd user
-
-MY_P="${P/_rc/RC}"
-
-DEBIAN_PV=1.11
-DEBIAN_PR="2"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
-
-DESCRIPTION="Simple relay-only local mail transport agent"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz"
-# mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="ssl"
-
-DEPEND="
- sys-apps/groff
- ssl? ( net-libs/gnutls )"
-RDEPEND="
- virtual/logger
- virtual/shadow
- ssl? ( net-libs/gnutls )
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/opensmtpd
- !mail-mta/ssmtp"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-# sed -i -e 's/nullmailer-1.10/nullmailer-1.11/g' \
-# "${WORKDIR}"/debian/patches/*.diff || die
-# EPATCH_OPTS="-d ${S} -p1" \
-# epatch "${DISTDIR}"/${DEBIAN_SRC}
- # why revert? Ask Robin when he is back!
-# EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
-# epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_configure() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf \
- --localstatedir=/var \
- $(use_enable ssl tls)
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-${PV} remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usability
- dodir /usr/$(get_libdir)
- dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer-r2 nullmailer
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- fi
- #echo
- #elog "To start nullmailer at boot you may use either the nullmailer init.d"
- #elog "script, or emerge sys-process/supervise-scripts, enable the"
- #elog "svscan init.d script and create the following link:"
- #elog "ln -fs /var/nullmailer/service /service/nullmailer"
- #echo
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}