summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-16 15:14:24 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-16 15:14:24 +0000
commitd7719c748d73e3ebc861e91099e3485835ec77cd (patch)
tree77d4ce59893db75d83153f7fff3e1a59d4d265e7 /mate-base
parenttest phase again updated subject to a bump of nose with the result that pypy ... (diff)
downloadgentoo-2-d7719c748d73e3ebc861e91099e3485835ec77cd.tar.gz
gentoo-2-d7719c748d73e3ebc861e91099e3485835ec77cd.tar.bz2
gentoo-2-d7719c748d73e3ebc861e91099e3485835ec77cd.zip
Revision bump, use cpupower instead of cpufrequtils; fixes bug #510034, reported by Pacho Ramos.
(Portage version: HEAD/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-applets/ChangeLog12
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.6.2-r1-replace-cpufreq-by-cpupower.patch79
-rw-r--r--mate-base/mate-applets/mate-applets-1.6.2-r1.ebuild (renamed from mate-base/mate-applets/mate-applets-1.6.2.ebuild)10
-rw-r--r--mate-base/mate-applets/mate-applets-1.8.0-r1.ebuild (renamed from mate-base/mate-applets/mate-applets-1.8.0.ebuild)8
4 files changed, 103 insertions, 6 deletions
diff --git a/mate-base/mate-applets/ChangeLog b/mate-base/mate-applets/ChangeLog
index 33de2043caae..9d0b08ee36af 100644
--- a/mate-base/mate-applets/ChangeLog
+++ b/mate-base/mate-applets/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for mate-base/mate-applets
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-applets/ChangeLog,v 1.4 2014/05/04 14:53:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-applets/ChangeLog,v 1.5 2014/05/16 15:14:24 tomwij Exp $
+
+*mate-applets-1.8.0-r1 (16 May 2014)
+*mate-applets-1.6.2-r1 (16 May 2014)
+
+ 16 May 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/mate-applets-1.6.2-r1-replace-cpufreq-by-cpupower.patch,
+ +mate-applets-1.6.2-r1.ebuild, +mate-applets-1.8.0-r1.ebuild,
+ -mate-applets-1.6.2.ebuild, -mate-applets-1.8.0.ebuild:
+ Revision bump, use cpupower instead of cpufrequtils; fixes bug #510034,
+ reported by Pacho Ramos.
04 May 2014; Agostino Sarubbo <ago@gentoo.org> mate-applets-1.6.2.ebuild:
Stable for amd64, wrt bug #509268
diff --git a/mate-base/mate-applets/files/mate-applets-1.6.2-r1-replace-cpufreq-by-cpupower.patch b/mate-base/mate-applets/files/mate-applets-1.6.2-r1-replace-cpufreq-by-cpupower.patch
new file mode 100644
index 000000000000..880afc75b76b
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.6.2-r1-replace-cpufreq-by-cpupower.patch
@@ -0,0 +1,79 @@
+Obtained from: http://pkgs.fedoraproject.org/cgit/mate-applets.git/plain/cpufreq.patch
+
+diff -upr mate-applets-1.5.0-orig/configure.ac mate-applets-1.5.0/configure.ac
+--- mate-applets-1.5.0-orig/configure.ac 2012-12-08 22:37:32.000000000 +0100
++++ mate-applets-1.5.0/configure.ac 2013-01-14 18:04:15.726598991 +0100
+@@ -506,13 +506,13 @@ if test "x$HAVE_POLKIT" = "xyes"; then
+ fi
+
+ AC_CHECK_HEADER(cpufreq.h, have_libcpufreq=yes, have_libcpufreq=no)
+-LIBCPUFREQ_LIBS=
+-if test "x$have_libcpufreq" = "xyes"; then
+- AC_DEFINE([HAVE_LIBCPUFREQ], [1], [Have libcpufreq.])
+- LIBCPUFREQ_LIBS=-lcpufreq
++LIBCPUPOWER_LIBS=
++if test "x$have_libcpupower" = "xyes"; then
++ AC_DEFINE([HAVE_LIBCPUPOWER], [1], [Have libcpupower.])
++ LIBCPUPOWER_LIBS=-lcpupower
+ fi
+-AM_CONDITIONAL(HAVE_LIBCPUFREQ, test x$have_libcpufreq = xyes)
+-AC_SUBST(LIBCPUFREQ_LIBS)
++AM_CONDITIONAL(HAVE_LIBCPUPOWER, test x$have_libcpupower = xyes)
++AC_SUBST(LIBCPUPOWER_LIBS)
+
+ build_cpufreq_applet=no
+
+diff -upr mate-applets-1.5.0-orig/cpufreq/src/cpufreq-selector/cpufreq-selector-factory.c mate-applets-1.5.0/cpufreq/src/cpufreq-selector/cpufreq-selector-factory.c
+--- mate-applets-1.5.0-orig/cpufreq/src/cpufreq-selector/cpufreq-selector-factory.c 2012-12-08 22:37:32.000000000 +0100
++++ mate-applets-1.5.0/cpufreq/src/cpufreq-selector/cpufreq-selector-factory.c 2013-01-14 19:15:28.432366287 +0100
+@@ -24,7 +24,7 @@
+ #include "cpufreq-selector-factory.h"
+ #include "cpufreq-selector-sysfs.h"
+ #include "cpufreq-selector-procfs.h"
+-#ifdef HAVE_LIBCPUFREQ
++#ifdef HAVE_LIBCPUPOWER
+ #include "cpufreq-selector-libcpufreq.h"
+ #endif
+
+@@ -33,7 +33,7 @@ cpufreq_selector_factory_create_selector
+ {
+ CPUFreqSelector *selector = NULL;
+
+-#ifdef HAVE_LIBCPUFREQ
++#ifdef HAVE_LIBCPUPOWER
+ selector = cpufreq_selector_libcpufreq_new (cpu);
+ #else
+ if (g_file_test ("/sys/devices/system/cpu/cpu0/cpufreq", G_FILE_TEST_EXISTS)) { /* 2.6 kernel */
+@@ -41,7 +41,7 @@ cpufreq_selector_factory_create_selector
+ } else if (g_file_test ("/proc/cpufreq", G_FILE_TEST_EXISTS)) { /* 2.4 kernel */
+ selector = cpufreq_selector_procfs_new (cpu);
+ }
+-#endif /* HAVE_LIBCPUFREQ */
++#endif /* HAVE_LIBCPUPOWER */
+
+ return selector;
+ }
+diff -upr mate-applets-1.5.0-orig/cpufreq/src/cpufreq-selector/Makefile.am mate-applets-1.5.0/cpufreq/src/cpufreq-selector/Makefile.am
+--- mate-applets-1.5.0-orig/cpufreq/src/cpufreq-selector/Makefile.am 2012-12-08 22:37:32.000000000 +0100
++++ mate-applets-1.5.0/cpufreq/src/cpufreq-selector/Makefile.am 2013-01-14 19:13:27.223180712 +0100
+@@ -16,7 +16,7 @@ if CPUFREQ_SELECTOR_SUID
+ endif
+
+
+-if HAVE_LIBCPUFREQ
++if HAVE_LIBCPUPOWER
+ cpufreq_files=cpufreq-selector-libcpufreq.c cpufreq-selector-libcpufreq.h
+ endif
+
+diff -upr mate-applets-1.5.0-orig/cpufreq/src/Makefile.am mate-applets-1.5.0/cpufreq/src/Makefile.am
+--- mate-applets-1.5.0-orig/cpufreq/src/Makefile.am 2012-12-08 22:37:32.000000000 +0100
++++ mate-applets-1.5.0/cpufreq/src/Makefile.am 2013-01-14 19:14:01.647517888 +0100
+@@ -12,7 +12,7 @@ INCLUDES = \
+
+ libexec_PROGRAMS = mate-cpufreq-applet
+
+-if HAVE_LIBCPUFREQ
++if HAVE_LIBCPUPOWER
+ cpufreq_files=cpufreq-monitor-libcpufreq.c cpufreq-monitor-libcpufreq.h
+ endif
+
diff --git a/mate-base/mate-applets/mate-applets-1.6.2.ebuild b/mate-base/mate-applets/mate-applets-1.6.2-r1.ebuild
index 41869fa056d0..3ace42659f72 100644
--- a/mate-base/mate-applets/mate-applets-1.6.2.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.6.2-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-applets/mate-applets-1.6.2.ebuild,v 1.3 2014/05/04 14:53:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-applets/mate-applets-1.6.2-r1.ebuild,v 1.1 2014/05/16 15:14:24 tomwij Exp $
EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python2_{6,7} )
-inherit gnome2 python-single-r1 versionator
+inherit eutils gnome2 python-single-r1 versionator
MATE_BRANCH="$(get_version_component_range 1-2)"
@@ -35,7 +35,7 @@ RDEPEND="${PYTHON_DEPS}
>=mate-base/mate-settings-daemon-1.6:0
>=mate-extra/mate-character-map-1.6:0
>=sys-apps/dbus-1.1.2:0
- sys-power/cpufrequtils:0
+ sys-power/cpupower:0
>=sys-power/upower-0.9.4:0
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-2.20:2
@@ -59,6 +59,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-replace-cpufreq-by-cpupower.patch
+}
+
src_configure() {
gnome2_src_configure \
--libexecdir=/usr/libexec/mate-applets \
diff --git a/mate-base/mate-applets/mate-applets-1.8.0.ebuild b/mate-base/mate-applets/mate-applets-1.8.0-r1.ebuild
index a126af2dd1ef..e779f5700816 100644
--- a/mate-base/mate-applets/mate-applets-1.8.0.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-applets/mate-applets-1.8.0.ebuild,v 1.1 2014/04/17 15:45:48 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/mate-base/mate-applets/mate-applets-1.8.0-r1.ebuild,v 1.1 2014/05/16 15:14:24 tomwij Exp $
EAPI="5"
@@ -34,7 +34,7 @@ RDEPEND="${PYTHON_DEPS}
>=mate-base/mate-panel-1.8:0
>=mate-base/mate-settings-daemon-1.6:0
>=sys-apps/dbus-1.1.2:0
- sys-power/cpufrequtils:0
+ sys-power/cpupower:0
>=sys-power/upower-0.9.4:0
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-2.24:2
@@ -58,6 +58,10 @@ DEPEND="${RDEPEND}
sys-devel/gettext:*
virtual/pkgconfig:*"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.6.2-r1-replace-cpufreq-by-cpupower.patch
+}
+
src_configure() {
gnome2_src_configure \
--libexecdir=/usr/libexec/mate-applets \