summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-06-17 05:23:44 +0000
committerSlawek Lis <slis@gentoo.org>2014-06-17 05:23:44 +0000
commit865212b80767c7afd00cd42bd524689225bec600 (patch)
tree401db96e0c08e93b025e859058c6544047362d90 /media-gfx/assimp
parentAdd arm love. (diff)
downloadgentoo-2-865212b80767c7afd00cd42bd524689225bec600.tar.gz
gentoo-2-865212b80767c7afd00cd42bd524689225bec600.tar.bz2
gentoo-2-865212b80767c7afd00cd42bd524689225bec600.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'media-gfx/assimp')
-rw-r--r--media-gfx/assimp/ChangeLog9
-rw-r--r--media-gfx/assimp/assimp-3.1.1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/media-gfx/assimp/ChangeLog b/media-gfx/assimp/ChangeLog
index b3c1cb8d73e0..3b53313627e9 100644
--- a/media-gfx/assimp/ChangeLog
+++ b/media-gfx/assimp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/assimp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/assimp/ChangeLog,v 1.1 2013/05/22 06:56:32 slis Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/assimp/ChangeLog,v 1.2 2014/06/17 05:23:44 slis Exp $
+
+*assimp-3.1.1 (17 Jun 2014)
+
+ 17 Jun 2014; Sławek Lis <slis@gentoo.org> +assimp-3.1.1.ebuild:
+ Version bump
*assimp-3.0.1270 (22 May 2013)
diff --git a/media-gfx/assimp/assimp-3.1.1.ebuild b/media-gfx/assimp/assimp-3.1.1.ebuild
new file mode 100644
index 000000000000..56e339a43c0e
--- /dev/null
+++ b/media-gfx/assimp/assimp-3.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/assimp/assimp-3.1.1.ebuild,v 1.1 2014/06/17 05:23:44 slis Exp $
+
+EAPI=5
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Importer library to import assets from 3D files"
+HOMEPAGE="http://assimp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="+boost samples static tools"
+SLOT="0"
+
+DEPEND="
+ boost? ( dev-libs/boost )
+ samples? ( x11-libs/libX11 virtual/opengl media-libs/freeglut )
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build samples ASSIMP_SAMPLES) \
+ $(cmake-utils_use_build tools ASSIMP_TOOLS) \
+ $(cmake-utils_use_build static STATIC_LIB) \
+ $(cmake-utils_use_enable !boost BOOST_WORKAROUND)
+ )
+
+ cmake-utils_src_configure
+} \ No newline at end of file