summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-10-07 06:14:54 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-10-07 06:14:54 +0000
commitce8b394b4db58862eed628e6181d6ce667ca161e (patch)
treeeb440587e4a6ba65c9da2bbe0b6c8ab7f5a25db0 /media-gfx/asymptote
parentBug #239671 - Fix the distcc workaround so it also works when ccache is enabled. (diff)
downloadgentoo-2-ce8b394b4db58862eed628e6181d6ce667ca161e.tar.gz
gentoo-2-ce8b394b4db58862eed628e6181d6ce667ca161e.tar.bz2
gentoo-2-ce8b394b4db58862eed628e6181d6ce667ca161e.zip
Dependencies corrected, less documentation is produced with USE=-doc. Closing bugs #238108, #238121, #239063.
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-tuxonice-r1 i686)
Diffstat (limited to 'media-gfx/asymptote')
-rw-r--r--media-gfx/asymptote/ChangeLog9
-rw-r--r--media-gfx/asymptote/asymptote-1.43-r1.ebuild228
-rw-r--r--media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch59
-rw-r--r--media-gfx/asymptote/metadata.xml3
4 files changed, 298 insertions, 1 deletions
diff --git a/media-gfx/asymptote/ChangeLog b/media-gfx/asymptote/ChangeLog
index 5755d8dfe083..f7343b44e1e8 100644
--- a/media-gfx/asymptote/ChangeLog
+++ b/media-gfx/asymptote/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/asymptote
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.20 2008/09/04 07:52:46 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/ChangeLog,v 1.21 2008/10/07 06:14:53 grozin Exp $
+
+*asymptote-1.43-r1 (07 Oct 2008)
+
+ 07 Oct 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/asymptote-1.43-r1-configure-ac.patch, +asymptote-1.43-r1.ebuild:
+ Dependencies corrected, less documentation is produced with USE=-doc.
+ Closing bugs #238108, #238121, #239063.
04 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
asymptote-1.29.ebuild, asymptote-1.41.ebuild:
diff --git a/media-gfx/asymptote/asymptote-1.43-r1.ebuild b/media-gfx/asymptote/asymptote-1.43-r1.ebuild
new file mode 100644
index 000000000000..4c073ef05135
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-1.43-r1.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/asymptote/asymptote-1.43-r1.ebuild,v 1.1 2008/10/07 06:14:53 grozin Exp $
+EAPI=2
+inherit eutils autotools elisp-common latex-package multilib python
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex python sigsegv vim-syntax X"
+
+RDEPEND=">=sys-libs/readline-4.3-r5
+ >=sys-libs/ncurses-5.4-r5
+ imagemagick? ( media-gfx/imagemagick[png] )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[-nocxx] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ X? ( x11-misc/xdg-utils dev-lang/python dev-python/imaging[tk] )
+ python? ( dev-lang/python )
+ latex? ( virtual/latex-base )
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? ( dev-lang/perl virtual/texi2dvi virtual/latex-base media-gfx/imagemagick[png] )"
+
+pkg_setup() {
+ if use latex; then
+ # Calculating ASY_TEXMFDIR
+ local TEXMFPATH="$(kpsewhich -var-value=TEXMFSITE)"
+ local TEXMFCONFIGFILE="$(kpsewhich texmf.cnf)"
+
+ if [ -z "${TEXMFPATH}" ]; then
+ eerror "You haven't defined the TEXMFSITE variable in your TeX config."
+ eerror "Please do so in the file ${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf}"
+ die "Define TEXMFSITE in TeX configuration!"
+ else
+ # go through the colon separated list of directories
+ # (maybe only one) provided in the variable
+ # TEXMFPATH (generated from TEXMFSITE from TeX's config)
+ # and choose only the first entry.
+ # All entries are separated by colons, even when defined
+ # with semi-colons, kpsewhich changes
+ # the output to a generic format, so IFS has to be redefined.
+ local IFS="${IFS}:"
+
+ for strippedpath in ${TEXMFPATH}; do
+ if [ -d ${strippedpath} ]; then
+ ASY_TEXMFDIR="${strippedpath}"
+ break
+ fi
+ done
+
+ # verify if an existing path was chosen to prevent from
+ # installing into the wrong directory
+ if [ -z ${ASY_TEXMFDIR} ]; then
+ eerror "TEXMFSITE does not contain any existing directory."
+ eerror "Please define an existing directory in your TeX config file"
+ eerror "${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf} or create at least one of the there specified directories"
+ die "TEXMFSITE variable did not contain an existing directory"
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ # Fixing fftwl, gsl, sigsegv enabling
+ epatch "${FILESDIR}/${PF}-configure-ac.patch"
+ einfo "Patching configure.ac"
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ # Changing pdf, ps, image viewers to xdg-open
+ epatch "${FILESDIR}/${P}-xdg-utils.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # http://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with sigsegv)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ cd doc
+ emake asy.1 || die "emake asy.1 failed"
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info || die "emake ${PN}.info failed"
+ # html
+ einfo "Making html docs"
+ emake ${PN}/index.html
+ einfo "Making FAQ"
+ cd FAQ
+ emake
+ cd ..
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ emake asymptote.pdf
+ emake CAD.pdf
+ fi
+ cd ..
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ # the program
+ exeinto /usr/bin
+ doexe asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ insinto /usr/share/${PN}/GUI
+ doins GUI/*.py
+ dosym /usr/share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins examples/*.asy \
+ examples/*.eps \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc
+ insinto "${ASY_TEXMFDIR}"/tex/latex
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ fi
+ cd ..
+ fi
+
+ # asymptote.py
+ if use python; then
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins base/${PN}.py
+ fi
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc
+ doinfo ${PN}.info*
+ dohtml ${PN}/*
+ cd FAQ
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ insinto /usr/share/doc/${PF}/html/FAQ
+ doins asy-faq.html/*
+ cd ..
+ insinto /usr/share/doc/${PF}
+ doins ${PN}.pdf CAD.pdf
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_compile \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}.py
+ fi
+
+ use latex && latex-package_rehash
+
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+ use python && python_mod_cleanup
+}
diff --git a/media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch
new file mode 100644
index 000000000000..8d9ba5dc1cab
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch
@@ -0,0 +1,59 @@
+diff -U2 -r asymptote-1.43.orig/configure.ac asymptote-1.43/configure.ac
+--- asymptote-1.43.orig/configure.ac 2008-06-12 14:42:50.000000000 +0700
++++ asymptote-1.43/configure.ac 2008-10-03 20:15:51.000000000 +0700
+@@ -77,8 +77,14 @@
+ fi
+
+-AC_CHECK_HEADER(fftw3.h,
+- AC_CHECK_LIB([fftw3], fftw_execute,,
++AC_ARG_WITH([fftw],
++ [ --with-fftw use fftw3],
++ [with_fftw=$withval],
++ [with_fftw="no"])
++if test "$with_fftw" = "yes"; then
++AC_CHECK_HEADER([fftw3.h],
++ AC_CHECK_LIB([fftw3], [fftw_execute],,
+ AC_MSG_NOTICE([*** Could not find libfftw3: will compile without optional fast Fourier transforms. ***])),
+ AC_MSG_NOTICE([*** Header file fftw3.h not found: will compile without optional fast Fourier transforms. ***]))
++fi
+
+ GCVERSION=gc-7.1
+@@ -117,5 +123,5 @@
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+@@ -182,5 +188,14 @@
+ AC_CHECK_LIB([curses], [setupterm]))
+ AC_CHECK_LIB([m], [sqrt])
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER(sigsegv.h,
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
+
+ AC_CHECK_LIB([readline], [rl_completion_matches],,
+@@ -198,4 +213,9 @@
+ AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
+
++AC_ARG_WITH(gsl,
++ [ --with-gsl use gsl libraries],
++ [with_gsl=$withval],
++ [with_gsl="no"])
++if test "$with_gsl" = "yes"; then
+ AC_CHECK_HEADER(gsl/gsl_sf.h,
+ AC_CHECK_LIB([gsl], gsl_sf_Si, [AC_DEFINE(HAVE_LIBGSL, 1,
+@@ -203,4 +223,5 @@
+ AC_MSG_NOTICE([*** Could not find libgsl: will compile without optional special functions. ***]),[-lgslcblas]),
+ AC_MSG_NOTICE([*** Header file gsl_sf.h not found: will compile without optional special functions. ***]))
++fi
+
+ TRIANGLE=Delaunay
diff --git a/media-gfx/asymptote/metadata.xml b/media-gfx/asymptote/metadata.xml
index b60d13756716..31fd956a8cc7 100644
--- a/media-gfx/asymptote/metadata.xml
+++ b/media-gfx/asymptote/metadata.xml
@@ -19,5 +19,8 @@
<flag name='boehm-gc'>
Enables using the Boehm-Demers-Weiser conservative garbage collector
</flag>
+ <flag name='sigsegv'>
+ Enables using <pkg>dev-libs/libsigsegv</pkg>
+ </flag>
</use>
</pkgmetadata>