summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-03-05 23:34:41 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-03-05 23:34:41 +0000
commit076d4a204cf64b2d3bdde210f0b10f74bc377c10 (patch)
tree204acf9b984bfda37299b694f6e4671db8b193ec /media-gfx/exiv2
parentrm old version (diff)
downloadgentoo-2-076d4a204cf64b2d3bdde210f0b10f74bc377c10.tar.gz
gentoo-2-076d4a204cf64b2d3bdde210f0b10f74bc377c10.tar.bz2
gentoo-2-076d4a204cf64b2d3bdde210f0b10f74bc377c10.zip
version bump. new version features nls support and iconv is now a mandantory runtime dependency.
(Portage version: 2.1.2-r2)
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/ChangeLog9
-rw-r--r--media-gfx/exiv2/exiv2-0.13.ebuild60
-rw-r--r--media-gfx/exiv2/files/digest-exiv2-0.133
-rw-r--r--media-gfx/exiv2/metadata.xml3
4 files changed, 73 insertions, 2 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index 61cd47db4b1d..dc7ef87a7ecc 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.16 2007/02/01 15:03:22 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.17 2007/03/05 23:34:41 sbriesen Exp $
+
+*exiv2-0.13 (05 Mar 2007)
+
+ 05 Mar 2007; Stefan Briesenick <sbriesen@gentoo.org> metadata.xml,
+ +exiv2-0.13.ebuild:
+ version bump. new version features nls support and iconv is now a mandantory
+ runtime dependency.
01 Feb 2007; Gustavo Zacarias <gustavoz@gentoo.org> exiv2-0.12.ebuild:
Stable on sparc
diff --git a/media-gfx/exiv2/exiv2-0.13.ebuild b/media-gfx/exiv2/exiv2-0.13.ebuild
new file mode 100644
index 000000000000..68f8ed2e7938
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.13.ebuild,v 1.1 2007/03/05 23:34:41 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+SRC_URI="http://www.exiv2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc nls zlib unicode"
+IUSE_LINGUAS="de es fi fr pl ru"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use unicode; then
+ einfo "Converting docs to UTF-8"
+ for i in doc/cmd.txt; do
+ iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+ use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README doc/{ChangeLog,cmd.txt}
+ use doc && dohtml doc/html/*
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "PLEASE PLEASE take note of this:"
+ ewarn "Please make *sure* to run revdep-rebuild now"
+ ewarn "Certain things on your system may have linked against a"
+ ewarn "different version of exiv2 -- those things need to be"
+ ewarn "recompiled. Sorry for the inconvenience!"
+ ewarn
+}
diff --git a/media-gfx/exiv2/files/digest-exiv2-0.13 b/media-gfx/exiv2/files/digest-exiv2-0.13
new file mode 100644
index 000000000000..d722949efd95
--- /dev/null
+++ b/media-gfx/exiv2/files/digest-exiv2-0.13
@@ -0,0 +1,3 @@
+MD5 492d476e3130ac27983d93e5595d81e8 exiv2-0.13.tar.gz 2841724
+RMD160 e06de2dfeb6941b1fd501bff258763f2f13f98b9 exiv2-0.13.tar.gz 2841724
+SHA256 f1d38ed31bdb54f6c5c80f7cd6765025cac535883b24e630f5bbe5c63e5cff75 exiv2-0.13.tar.gz 2841724
diff --git a/media-gfx/exiv2/metadata.xml b/media-gfx/exiv2/metadata.xml
index e9851b4db295..2f40fbe7aeaf 100644
--- a/media-gfx/exiv2/metadata.xml
+++ b/media-gfx/exiv2/metadata.xml
@@ -7,6 +7,7 @@
<name>Stefan Briesenick</name>
</maintainer>
<longdescription lang="en">
- Exiv2 is a C++ library and a command line utility to access image metadata.
+ Exiv2 is a C++ library and a command line utility to read and
+ write EXIF and IPTC image metadata.
</longdescription>
</pkgmetadata>