summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-26 19:00:32 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-26 19:00:32 +0000
commit75e0f7bf70193839f689b8e040f54bd71c62dc75 (patch)
treeb33af490af1f6996fd180e2ca0dbd450357e8d9e /media-gfx/gimp-print
parentNew ebuild (because sometimes I _still_ have to connect to an IBM mainframe!) (diff)
downloadgentoo-2-75e0f7bf70193839f689b8e040f54bd71c62dc75.tar.gz
gentoo-2-75e0f7bf70193839f689b8e040f54bd71c62dc75.tar.bz2
gentoo-2-75e0f7bf70193839f689b8e040f54bd71c62dc75.zip
update and fixes
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/files/digest-gimp-print-4.1.99_beta31
-rw-r--r--media-gfx/gimp-print/gimp-print-4.1.99_beta3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-gfx/gimp-print/files/digest-gimp-print-4.1.99_beta3 b/media-gfx/gimp-print/files/digest-gimp-print-4.1.99_beta3
new file mode 100644
index 000000000000..472ab4f9521c
--- /dev/null
+++ b/media-gfx/gimp-print/files/digest-gimp-print-4.1.99_beta3
@@ -0,0 +1 @@
+MD5 93060c55477af4632dc4af701c956175 gimp-print-4.1.99-b3.tar.gz 3899392
diff --git a/media-gfx/gimp-print/gimp-print-4.1.99_beta3.ebuild b/media-gfx/gimp-print/gimp-print-4.1.99_beta3.ebuild
new file mode 100644
index 000000000000..a782a97d91d0
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.1.99_beta3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+
+MY_P="${PN}-`echo ${PV} |sed -e 's:_:-:' -e 's:eta::'`"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
+SRC_URI="http://prdownloads.sourceforge.net/gimp-print/${MY_P}.tar.gz"
+HOMEPAGE="http://gimp-print.sourceforge.net/"
+
+DEPEND=">=media-gfx/gimp-1.2.1"
+
+RDEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/gimp/1.2/ \
+ --with-gimp-exec-prefix=/usr \
+ || die
+
+ cp src/gimp/Makefile src/gimp/Makefile.orig
+ sed -e 's:--install-admin-bin:--install-bin:g' \
+ src/gimp/Makefile.orig >src/gimp/Makefile
+
+ make || die
+}
+
+src_install() {
+
+ dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/gimp/1.2/ \
+ HOME=${D}/usr/lib/gimp/1.2/ \
+ install || die
+
+ # NOTE: this build use gimptool to install the plugin, so
+ # if we dont do it this way, it will install to / no
+ # matter what.
+ mv ${D}/usr/lib/gimp/1.2/.gimp-1.2/plug-ins/ \
+ ${D}/usr/lib/gimp/1.2/
+ rm -rf ${D}/usr/lib/gimp/1.2/.gimp-1.2/
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README*
+}
+