summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-04-28 07:33:27 +0000
committerHanno Böck <hanno@gentoo.org>2007-04-28 07:33:27 +0000
commit440ba1d05fd885a4184ebdc7e171e35cb5cc2d65 (patch)
treea34211a1facc70dc6a5ec3b8385c818e55dbe8b2 /media-gfx/gimp/gimp-9999.ebuild
parentDo a large cleanup of the keepalived ebuild, so that it will build without ke... (diff)
downloadgentoo-2-440ba1d05fd885a4184ebdc7e171e35cb5cc2d65.tar.gz
gentoo-2-440ba1d05fd885a4184ebdc7e171e35cb5cc2d65.tar.bz2
gentoo-2-440ba1d05fd885a4184ebdc7e171e35cb5cc2d65.zip
gimp bumps with security fix
(Portage version: 2.1.2.5)
Diffstat (limited to 'media-gfx/gimp/gimp-9999.ebuild')
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild62
1 files changed, 33 insertions, 29 deletions
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index 8779ca42084d..fb420079874f 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-9999.ebuild,v 1.8 2007/04/21 04:34:25 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-9999.ebuild,v 1.9 2007/04/28 07:33:27 hanno Exp $
inherit subversion fdo-mime flag-o-matic
@@ -14,36 +14,37 @@ LICENSE="GPL-2"
SLOT="2"
KEYWORDS=""
-IUSE="alsa aalib altivec debug doc gtkhtml gnome jpeg lcms mmx mng pdf png python smp sse svg tiff wmf"
+IUSE="alsa aalib altivec curl debug doc gtkhtml gnome jpeg lcms mmx mng pdf png python smp sse svg tiff wmf"
RDEPEND=">=dev-libs/glib-2.12.3
- >=x11-libs/gtk+-2.8.20-r1
- >=x11-libs/pango-1.12.2
- >=media-libs/freetype-2.1.7
- >=media-libs/fontconfig-2.2.0
- >=media-libs/libart_lgpl-2.3.8-r1
- sys-libs/zlib
- dev-libs/libxml2
- dev-libs/libxslt
- x11-themes/hicolor-icon-theme
- aalib? ( media-libs/aalib )
- alsa? ( >=media-libs/alsa-lib-1.0.0 )
- doc? ( app-doc/gimp-help )
- gnome? ( >=gnome-base/gnome-vfs-2.10.0
- >=gnome-base/libgnomeui-2.10.0
- >=gnome-base/gnome-keyring-0.4.5 )
- gtkhtml? ( =gnome-extra/gtkhtml-2* )
- jpeg? ( >=media-libs/jpeg-6b-r2
- >=media-libs/libexif-0.6.0 )
- lcms? ( media-libs/lcms )
- mng? ( media-libs/libmng )
- pdf? ( >=app-text/poppler-bindings-0.3.1 )
- png? ( >=media-libs/libpng-1.2.2 )
- python? ( >=dev-lang/python-2.2.1
- >=dev-python/pygtk-2.8 )
- tiff? ( >=media-libs/tiff-3.5.7 )
- svg? ( >=gnome-base/librsvg-2.8.0 )
- wmf? ( >=media-libs/libwmf-0.2.8 )"
+ >=x11-libs/gtk+-2.8.20-r1
+ >=x11-libs/pango-1.12.2
+ >=media-libs/freetype-2.1.7
+ >=media-libs/fontconfig-2.2.0
+ >=media-libs/libart_lgpl-2.3.8-r1
+ sys-libs/zlib
+ dev-libs/libxml2
+ dev-libs/libxslt
+ x11-themes/hicolor-icon-theme
+ aalib? ( media-libs/aalib )
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+ curl? ( net-misc/curl )
+ doc? ( app-doc/gimp-help )
+ gnome? ( >=gnome-base/gnome-vfs-2.10.0
+ >=gnome-base/libgnomeui-2.10.0
+ >=gnome-base/gnome-keyring-0.4.5 )
+ gtkhtml? ( =gnome-extra/gtkhtml-2* )
+ jpeg? ( >=media-libs/jpeg-6b-r2
+ >=media-libs/libexif-0.6.0 )
+ lcms? ( media-libs/lcms )
+ mng? ( media-libs/libmng )
+ pdf? ( >=app-text/poppler-bindings-0.3.1 )
+ png? ( >=media-libs/libpng-1.2.2 )
+ python? ( >=dev-lang/python-2.2.1
+ >=dev-python/pygtk-2.8 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svg? ( >=gnome-base/librsvg-2.8.0 )
+ wmf? ( >=media-libs/libwmf-0.2.8 )"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
>=dev-util/intltool-0.31
@@ -75,8 +76,10 @@ src_compile() {
$(use_with aalib aa) \
$(use_with alsa) \
$(use_enable altivec) \
+ $(use_with curl) \
$(use_enable debug) \
$(use_enable doc gtk-doc) \
+ $(use_with gnome) \
$(use_with gtkhtml gtkhtml2) \
$(use_with jpeg libjpeg) \
$(use_with jpeg libexif) \
@@ -90,6 +93,7 @@ src_compile() {
$(use_enable sse) \
$(use_with svg librsvg) \
$(use_with tiff libtiff) \
+ $(use_with wmf) \
|| die "econf failed"
emake || die "emake failed"