summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-14 15:48:30 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-14 15:48:30 +0000
commit583d34e02b290b8cf52704a82447f64bb7bf76ff (patch)
tree70cb953f6eeaf9efa71c351f322462070f53f7ae /media-gfx/iscan-data
parentStable on alpha, bug 536008 (diff)
downloadgentoo-2-583d34e02b290b8cf52704a82447f64bb7bf76ff.tar.gz
gentoo-2-583d34e02b290b8cf52704a82447f64bb7bf76ff.tar.bz2
gentoo-2-583d34e02b290b8cf52704a82447f64bb7bf76ff.zip
bump, ebuild supplied by proxy maintainer via bug #487988
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'media-gfx/iscan-data')
-rw-r--r--media-gfx/iscan-data/ChangeLog9
-rw-r--r--media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/media-gfx/iscan-data/ChangeLog b/media-gfx/iscan-data/ChangeLog
index 81916866216f..8b1a6fda8b47 100644
--- a/media-gfx/iscan-data/ChangeLog
+++ b/media-gfx/iscan-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/iscan-data
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-data/ChangeLog,v 1.15 2014/12/12 17:24:51 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-data/ChangeLog,v 1.16 2015/07/14 15:48:30 idella4 Exp $
+
+*iscan-data-1.36.0.1 (14 Jul 2015)
+
+ 14 Jul 2015; Ian Delaney <idella4@gentoo.org> +iscan-data-1.36.0.1.ebuild:
+ bump, ebuild supplied by proxy maintainer via bug #487988
12 Dec 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
New maintainer
diff --git a/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild b/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
new file mode 100644
index 000000000000..5044961d8b7b
--- /dev/null
+++ b/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-data/iscan-data-1.36.0.1.ebuild,v 1.1 2015/07/14 15:48:30 idella4 Exp $
+
+EAPI=5
+
+inherit eutils versionator udev multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Image Scan! for Linux data files"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# Use a gentoo hosted url since upstream uses a session based url that causes the
+# files to no longer be available after the session expires.
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs//${PN}_${MY_PVR}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="udev"
+
+DEPEND="udev? (
+ dev-libs/libxslt
+ media-gfx/sane-backends
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=( NEWS SUPPORTED-DEVICES KNOWN-PROBLEMS )
+
+src_install() {
+ ewarn ""; ewarn "Some profiles automatically enable udev which will cause install to fail"
+ ewarn "if media-gfx/sane-backends is not already installed."; ewarn ""
+ default
+
+ if use udev; then
+ # create udev rules
+ local rulesdir=$(get_udevdir)/rules.d
+ dodir ${rulesdir}
+ "${D}usr/$(get_libdir)/iscan-data/make-policy-file" \
+ --force --mode udev \
+ -d "${D}usr/share/iscan-data/epkowa.desc" \
+ -o "${D}${rulesdir}/99-iscan.rules" || die
+ fi
+}