summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-23 05:24:57 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-23 05:24:57 +0000
commit1b9ebc428693fb3f4cc2c30cad3ec9620727a767 (patch)
tree505480db94c3f2e90ed9169154daee042bf0a3a9 /media-gfx/luminance-hdr
parentRestricting pypy and jython (diff)
downloadgentoo-2-1b9ebc428693fb3f4cc2c30cad3ec9620727a767.tar.gz
gentoo-2-1b9ebc428693fb3f4cc2c30cad3ec9620727a767.tar.bz2
gentoo-2-1b9ebc428693fb3f4cc2c30cad3ec9620727a767.zip
Respect user CFLAGS and use epatch directly instead of the PATCHES array.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/luminance-hdr')
-rw-r--r--media-gfx/luminance-hdr/ChangeLog5
-rw-r--r--media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild29
2 files changed, 20 insertions, 14 deletions
diff --git a/media-gfx/luminance-hdr/ChangeLog b/media-gfx/luminance-hdr/ChangeLog
index d42a93057f91..046a78a617d6 100644
--- a/media-gfx/luminance-hdr/ChangeLog
+++ b/media-gfx/luminance-hdr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/luminance-hdr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/luminance-hdr/ChangeLog,v 1.14 2012/02/14 09:47:16 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/luminance-hdr/ChangeLog,v 1.15 2012/02/23 05:24:57 radhermit Exp $
+
+ 23 Feb 2012; Tim Harder <radhermit@gentoo.org> luminance-hdr-2.2.0.ebuild:
+ Respect user CFLAGS and use epatch directly instead of the PATCHES array.
14 Feb 2012; Tim Harder <radhermit@gentoo.org> -luminance-hdr-2.0.1.ebuild,
-luminance-hdr-2.0.2.ebuild:
diff --git a/media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild b/media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild
index 7080668f960d..2c497c7e945b 100644
--- a/media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild
+++ b/media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild,v 1.2 2012/02/14 09:33:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/luminance-hdr/luminance-hdr-2.2.0.ebuild,v 1.3 2012/02/23 05:24:57 radhermit Exp $
EAPI="4"
-inherit cmake-utils toolchain-funcs
+inherit cmake-utils toolchain-funcs eutils
DESCRIPTION="Luminance HDR is a graphical user interface that provides a workflow for HDR imaging."
HOMEPAGE="http://qtpfsgui.sourceforge.net"
@@ -32,17 +32,6 @@ RDEPEND="${DEPEND}"
DOCS=( AUTHORS BUGS Changelog README TODO )
-PATCHES=(
- # Don't try to define the git version of the release
- "${FILESDIR}"/${P}-no-git.patch
-
- # Don't install extra docs and fix install dir
- "${FILESDIR}"/${P}-docs.patch
-
- # Fix openmp automagic support
- "${FILESDIR}"/${P}-openmp-automagic.patch
-)
-
S=${WORKDIR}
pkg_setup() {
@@ -51,6 +40,20 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # Don't try to define the git version of the release
+ epatch "${FILESDIR}"/${P}-no-git.patch
+
+ # Don't install extra docs and fix install dir
+ epatch "${FILESDIR}"/${P}-docs.patch
+
+ # Fix openmp automagic support
+ epatch "${FILESDIR}"/${P}-openmp-automagic.patch
+
+ # Respect user CFLAGS
+ sed -i -e "/-O3/d" CMakeLists.txt || die
+}
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_use openmp OPENMP)