summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-31 15:51:54 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-31 15:51:54 +0000
commite7978e9a11e5e0ece98b97070827f65c9c8bc287 (patch)
treecc5b53a3a99758b4bd3d9cfade76ad69a17a23b7 /media-gfx/nvidia-texture-tools/files
parentStable for amd64, wrt bug #462890 (diff)
downloadgentoo-2-e7978e9a11e5e0ece98b97070827f65c9c8bc287.tar.gz
gentoo-2-e7978e9a11e5e0ece98b97070827f65c9c8bc287.tar.bz2
gentoo-2-e7978e9a11e5e0ece98b97070827f65c9c8bc287.zip
fix clang build
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-gfx/nvidia-texture-tools/files')
-rw-r--r--media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch
new file mode 100644
index 000000000000..373c87e4171b
--- /dev/null
+++ b/media-gfx/nvidia-texture-tools/files/nvidia-texture-tools-2.0.8-clang.patch
@@ -0,0 +1,18 @@
+Index: src/src/nvtt/squish/CMakeLists.txt
+===================================================================
+--- src/src/nvtt/squish/CMakeLists.txt (revision 13060)
++++ src/src/nvtt/squish/CMakeLists.txt (working copy)
+@@ -22,7 +22,11 @@
+
+ ADD_LIBRARY(squish STATIC ${SQUISH_SRCS})
+
+-IF(CMAKE_COMPILER_IS_GNUCXX)
++IF("${CMAKE_CXX_COMPILER}" MATCHES "clang(\\+\\+)?$" OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
++ SET(CMAKE_COMPILER_IS_CLANGXX 1)
++ENDIF()
++
++IF(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_CLANGXX)
+ SET_TARGET_PROPERTIES(squish PROPERTIES COMPILE_FLAGS -fPIC)
+-ENDIF(CMAKE_COMPILER_IS_GNUCXX)
++ENDIF(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_CLANGXX)
+