summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-09 22:53:51 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-09 22:53:51 +0000
commit7547ef71dbe2f588f3109ffb44d750b59d3ce528 (patch)
tree99ced55478139444b617b2379d1439c98ee36193 /media-gfx/postr
parentstable ppc, bug #427054 (diff)
downloadgentoo-2-7547ef71dbe2f588f3109ffb44d750b59d3ce528.tar.gz
gentoo-2-7547ef71dbe2f588f3109ffb44d750b59d3ce528.tar.bz2
gentoo-2-7547ef71dbe2f588f3109ffb44d750b59d3ce528.zip
Bump with bugfixes, UI improvements, and internationalization. Switch to python.eclass due to upstream build system changes. Update license.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/postr')
-rw-r--r--media-gfx/postr/ChangeLog10
-rw-r--r--media-gfx/postr/files/postr-0.13-exception-after-quit.patch50
-rw-r--r--media-gfx/postr/metadata.xml4
-rw-r--r--media-gfx/postr/postr-0.12.4.ebuild4
-rw-r--r--media-gfx/postr/postr-0.13.ebuild78
5 files changed, 143 insertions, 3 deletions
diff --git a/media-gfx/postr/ChangeLog b/media-gfx/postr/ChangeLog
index 631604ebe05b..4eae966fa1a3 100644
--- a/media-gfx/postr/ChangeLog
+++ b/media-gfx/postr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/postr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/postr/ChangeLog,v 1.2 2012/05/21 18:07:56 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/postr/ChangeLog,v 1.3 2012/10/09 22:53:51 tetromino Exp $
+
+*postr-0.13 (09 Oct 2012)
+
+ 09 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org> postr-0.12.4.ebuild,
+ +postr-0.13.ebuild, +files/postr-0.13-exception-after-quit.patch,
+ metadata.xml:
+ Bump with bugfixes, UI improvements, and internationalization. Switch to
+ python.eclass due to upstream build system changes. Update license.
21 May 2012; Krzysztof Pawlik <nelchael@gentoo.org> postr-0.12.4.ebuild:
Remove calls to python-distutils-ng_redoscript, it is automated in eclass.
diff --git a/media-gfx/postr/files/postr-0.13-exception-after-quit.patch b/media-gfx/postr/files/postr-0.13-exception-after-quit.patch
new file mode 100644
index 000000000000..1235e9de05a2
--- /dev/null
+++ b/media-gfx/postr/files/postr-0.13-exception-after-quit.patch
@@ -0,0 +1,50 @@
+From 63b803acba957ea81946a86cd3f03dd34ed1779f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Germ=C3=A1n=20Poo-Caama=C3=B1o?= <gpoo@gnome.org>
+Date: Thu, 4 Oct 2012 00:32:31 -0700
+Subject: [PATCH] Fixed exception after quit
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This bug was silly. It caused an exception when python was
+cleaning up twisted before closing. It seems there was a callback
+in the stack that was trying to be applied to an object already
+released. This happened only when there were callbacks on
+callbacks in twisted.
+
+It seems that modules imported insude functions or methods
+are cleaned up differently than when they are imported at the
+beginning of a module. Or maybe is a bug in either twisted or
+bsddb3 that mess the garbage collector up.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=535572
+
+Signed-off-by: Germán Poo-Caamaño <gpoo@gnome.org>
+---
+ src/util.py | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/util.py b/src/util.py
+index 5ad3410..68ab8b8 100644
+--- a/src/util.py
++++ b/src/util.py
+@@ -16,7 +16,7 @@
+ # St, Fifth Floor, Boston, MA 02110-1301 USA
+
+ import gtk, os
+-
++import bsddb3
+
+ def greek(size):
+ """Take a quantity (like 1873627) and display it in a human-readable rounded
+@@ -71,7 +71,6 @@ def get_buddyicon(flickr, data, size=48):
+ """Lookup the buddyicon from the data in @data using @flickr and resize it
+ to @size pixels."""
+ from twisted.web.client import getPage
+- import bsddb3
+
+ global __buddy_cache
+ if __buddy_cache is None:
+--
+1.7.12
+
diff --git a/media-gfx/postr/metadata.xml b/media-gfx/postr/metadata.xml
index da6fd63d0085..c85aff7b6fc0 100644
--- a/media-gfx/postr/metadata.xml
+++ b/media-gfx/postr/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome</herd>
+<use>
+ <flag name="gnome2">Install plugin for <pkg>=gnome-base/nautilus-2*</pkg>.
+ Warning: will make =nautilus-3* crash.</flag>
+</use>
</pkgmetadata>
diff --git a/media-gfx/postr/postr-0.12.4.ebuild b/media-gfx/postr/postr-0.12.4.ebuild
index 402208d20c72..8ae5283a91eb 100644
--- a/media-gfx/postr/postr-0.12.4.ebuild
+++ b/media-gfx/postr/postr-0.12.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/postr/postr-0.12.4.ebuild,v 1.2 2012/05/21 18:07:56 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/postr/postr-0.12.4.ebuild,v 1.3 2012/10/09 22:53:51 tetromino Exp $
EAPI="4"
@@ -14,7 +14,7 @@ inherit gnome2 python-distutils-ng
DESCRIPTION="Flickr uploader for GNOME"
HOMEPAGE="http://projects.gnome.org/postr/"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
diff --git a/media-gfx/postr/postr-0.13.ebuild b/media-gfx/postr/postr-0.13.ebuild
new file mode 100644
index 000000000000..3108d924a619
--- /dev/null
+++ b/media-gfx/postr/postr-0.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/postr/postr-0.13.ebuild,v 1.1 2012/10/09 22:53:51 tetromino Exp $
+
+EAPI="4"
+
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="xml"
+
+inherit eutils gnome2 python
+
+DESCRIPTION="Flickr uploader for GNOME"
+HOMEPAGE="http://projects.gnome.org/postr/"
+
+LICENSE="GPL-2+ CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome2"
+
+COMMON_DEPEND="dev-python/pygtk:2
+ gnome2? (
+ >=dev-python/nautilus-python-0.6.1
+ <dev-python/nautilus-python-1.0 )"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/bsddb3
+ dev-python/dbus-python
+ dev-python/gconf-python
+ dev-python/gtkspell-python
+ dev-python/libgnome-python
+ dev-python/pygobject:2
+ dev-python/twisted
+ dev-python/twisted-web"
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-nautilus-extension-dir=${EPREFIX}/usr/share/nautilus-python/extensions"
+ python_pkg_setup
+}
+
+src_prepare() {
+ # In next release
+ epatch "${FILESDIR}/${P}-exception-after-quit.patch"
+
+ python_clean_py-compile_files
+ python_convert_shebangs 2 postr
+ if ! use gnome2; then
+ # Don't check for nautilus-python if we aren't installing the extension
+ sed -e 's:nautilus-python >= 0.6.1::' -i configure || die
+ fi
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ # In next release, https://bugzilla.gnome.org/show_bug.cgi?id=685454
+ mv "${ED}usr/share/postr/postr.glade" "${ED}$(python_get_sitedir)/postr/" || die
+ if ! use gnome2; then
+ rm -r "${ED}usr/share/nautilus-python" || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize postr
+ use gnome2 && python_mod_optimize /usr/share/nautilus-python/extensions/postrExtension.py
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup postr
+ use gnome2 && python_mod_cleanup /usr/share/nautilus-python/extensions/postrExtension.py
+ gnome2_pkg_postrm
+}