summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-03 12:23:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-03 12:23:41 +0000
commit83cf6aea2f35030f50c0dc921b1b5e3df8716535 (patch)
treebf50cbeb65bad62a5caa6f7106556c8b471e66c6 /media-gfx/ristretto
parentAdd patch to fix hang on BSD and OS X, bug #405951. (diff)
downloadgentoo-2-83cf6aea2f35030f50c0dc921b1b5e3df8716535.tar.gz
gentoo-2-83cf6aea2f35030f50c0dc921b1b5e3df8716535.tar.bz2
gentoo-2-83cf6aea2f35030f50c0dc921b1b5e3df8716535.zip
Version bump.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/ristretto')
-rw-r--r--media-gfx/ristretto/ChangeLog7
-rw-r--r--media-gfx/ristretto/ristretto-0.3.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-gfx/ristretto/ChangeLog b/media-gfx/ristretto/ChangeLog
index 27d121b5ab3a..35a8e282cc1c 100644
--- a/media-gfx/ristretto/ChangeLog
+++ b/media-gfx/ristretto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/ristretto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/ristretto/ChangeLog,v 1.58 2012/02/10 12:19:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ristretto/ChangeLog,v 1.59 2012/03/03 12:23:41 ssuominen Exp $
+
+*ristretto-0.3.5 (03 Mar 2012)
+
+ 03 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +ristretto-0.3.5.ebuild:
+ Version bump.
10 Feb 2012; Samuli Suominen <ssuominen@gentoo.org> ristretto-0.3.4.ebuild:
ppc/ppc64/x86 stable wrt #401229
diff --git a/media-gfx/ristretto/ristretto-0.3.5.ebuild b/media-gfx/ristretto/ristretto-0.3.5.ebuild
new file mode 100644
index 000000000000..95a35b3e7376
--- /dev/null
+++ b/media-gfx/ristretto/ristretto-0.3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ristretto/ristretto-0.3.5.ebuild,v 1.1 2012/03/03 12:23:41 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A fast and lightweight picture viewer for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/ristretto"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.90
+ >=dev-libs/glib-2.24
+ media-libs/libexif
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/exo-0.6
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfconf-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir=/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}