summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-09-09 23:52:10 +0000
committerMichael Januszewski <spock@gentoo.org>2005-09-09 23:52:10 +0000
commit116b13aae4433c241c2d00e3a7a073e71526ad4b (patch)
tree1a764bde99c02694d9e03f81ce088628954e5ca4 /media-gfx/splashutils
parentRemove awk compat crap as gawk now works on Darwin. (diff)
downloadgentoo-2-116b13aae4433c241c2d00e3a7a073e71526ad4b.tar.gz
gentoo-2-116b13aae4433c241c2d00e3a7a073e71526ad4b.tar.bz2
gentoo-2-116b13aae4433c241c2d00e3a7a073e71526ad4b.zip
Changed the way the src dir variables are defined and exported.
(Portage version: 1.589-cvs)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild b/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild
index 14c947df14a1..75f75406a41d 100644
--- a/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild,v 1.4 2005/09/09 13:11:05 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild,v 1.5 2005/09/09 23:52:10 spock Exp $
inherit eutils multilib linux-mod
@@ -11,6 +11,11 @@ V_PNG="1.2.8"
V_ZLIB="1.2.3"
V_FT="2.1.9"
+ZLIBSRC="libs/zlib-${V_ZLIB}"
+LPNGSRC="libs/libpng-${V_PNG}"
+JPEGSRC="libs/jpeg-${V_JPEG}"
+FT2SRC="libs/freetype-${V_FT}"
+
IUSE="hardened png truetype kdgraphics"
DESCRIPTION="Framebuffer splash utilities."
@@ -120,7 +125,7 @@ src_compile() {
cd ${SM}
emake LIB=$(get_libdir) || die "failed to build miscsplashutils"
cd ${S}
- export ZLIBSRC="libs/zlib-${V_ZLIB}"
+ export ZLIBSRC LPNGSRC JPEGSRC FT2SRC
emake -j1 LIB=$(get_libdir) || die "failed to build splashutils"
}
@@ -128,6 +133,7 @@ src_install() {
cd ${SM}
make DESTDIR=${D} install || die
+ export ZLIBSRC LPNGSRC JPEGSRC FT2SRC
cd ${S}
make DESTDIR=${D} install || die