summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-03-21 01:35:11 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-03-21 01:35:11 +0000
commit12759c1fafbfcfbc85757c8332d41fae420d4e22 (patch)
tree7047f5bcee119c79083e8d274f7306488dddd292 /media-gfx/tuxpaint
parentStable on alpha. (diff)
downloadgentoo-2-12759c1fafbfcfbc85757c8332d41fae420d4e22.tar.gz
gentoo-2-12759c1fafbfcfbc85757c8332d41fae420d4e22.tar.bz2
gentoo-2-12759c1fafbfcfbc85757c8332d41fae420d4e22.zip
Patch for 0.9.13-r1. Resolves bug #82598.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-gfx/tuxpaint')
-rw-r--r--media-gfx/tuxpaint/ChangeLog8
-rw-r--r--media-gfx/tuxpaint/files/tuxpaint-0.9.13-fix_error_directives.patch36
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild4
3 files changed, 46 insertions, 2 deletions
diff --git a/media-gfx/tuxpaint/ChangeLog b/media-gfx/tuxpaint/ChangeLog
index 8b0ef1f6685a..205d89838b7a 100644
--- a/media-gfx/tuxpaint/ChangeLog
+++ b/media-gfx/tuxpaint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/tuxpaint
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/ChangeLog,v 1.12 2005/03/20 21:26:00 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/ChangeLog,v 1.13 2005/03/21 01:35:10 leonardop Exp $
+
+ 20 Mar 2005; Leonardo Boshell <leonardop@gentoo.org>
+ tuxpaint-0.9.13-r1.ebuild,
+ files/tuxpaint-0.9.13-fix_error_directives.patch:
+ Added a patch to remove a few useless #error directives that were breaking
+ compilation. Resolves bug #82598.
*tuxpaint-0.9.14 (20 Mar 2005)
diff --git a/media-gfx/tuxpaint/files/tuxpaint-0.9.13-fix_error_directives.patch b/media-gfx/tuxpaint/files/tuxpaint-0.9.13-fix_error_directives.patch
new file mode 100644
index 000000000000..f63f4d42e27d
--- /dev/null
+++ b/media-gfx/tuxpaint/files/tuxpaint-0.9.13-fix_error_directives.patch
@@ -0,0 +1,36 @@
+diff -NurdB tuxpaint-0.9.13-orig/src/tuxpaint.c tuxpaint-0.9.13/src/tuxpaint.c
+--- tuxpaint-0.9.13-orig/src/tuxpaint.c 2005-03-20 20:19:44.000000000 -0500
++++ tuxpaint-0.9.13/src/tuxpaint.c 2005-03-20 20:20:17.000000000 -0500
+@@ -165,32 +165,11 @@
+ #endif
+
+ #include "SDL_image.h"
+-#ifndef _IMG_h
+-#error "---------------------------------------------------"
+-#error "If you installed SDL_image from a package, be sure"
+-#error "to get the development package, as well!"
+-#error "(e.g., 'libsdl-image1.2-devel.rpm')"
+-#error "---------------------------------------------------"
+-#endif
+
+ #include "SDL_ttf.h"
+-#ifndef _SDLttf_h
+-#error "---------------------------------------------------"
+-#error "If you installed SDL_ttf from a package, be sure"
+-#error "to get the development package, as well!"
+-#error "(e.g., 'libsdl-ttf1.2-devel.rpm')"
+-#error "---------------------------------------------------"
+-#endif
+
+ #ifndef NOSOUND
+ #include "SDL_mixer.h"
+-#ifndef _MIXER_H_
+-#error "---------------------------------------------------"
+-#error "If you installed SDL_mixer from a package, be sure"
+-#error "to get the development package, as well!"
+-#error "(e.g., 'libsdl-mixer1.2-devel.rpm')"
+-#error "---------------------------------------------------"
+-#endif
+ #endif
+
+ #ifndef SAVE_AS_BMP
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild
index 7dc8f4938592..fdb2a45f39fa 100644
--- a/media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild
+++ b/media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild,v 1.3 2005/03/20 21:26:00 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/tuxpaint-0.9.13-r1.ebuild,v 1.4 2005/03/21 01:35:10 leonardop Exp $
inherit eutils
@@ -30,6 +30,8 @@ src_unpack() {
# Sanitize the hack that is its Makefile
epatch ${DISTDIR}/${P}-makefile.patch
+ # Remove outdated error directives that break compilation. See bug #82598.
+ epatch ${FILESDIR}/${P}-fix_error_directives.patch
}
src_compile() {