summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-08-07 18:01:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-08-07 18:01:03 +0000
commit430e957026d4e023a41a3ec11b6414562551f8d0 (patch)
tree036f398704c6b485c4f9052f29b299a710730977 /media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
parentx86 stable wrt security bug #301828 (diff)
downloadgentoo-2-430e957026d4e023a41a3ec11b6414562551f8d0.tar.gz
gentoo-2-430e957026d4e023a41a3ec11b6414562551f8d0.tar.bz2
gentoo-2-430e957026d4e023a41a3ec11b6414562551f8d0.zip
Added missing deps, thanks to Nikoli
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild')
-rw-r--r--media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild b/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
index cab71a649b1e..48d6ed6ec978 100644
--- a/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild,v 1.1 2010/08/06 13:43:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/uniconvertor/uniconvertor-1.1.5.ebuild,v 1.2 2010/08/07 18:01:02 jlec Exp $
-EAPI=2
+EAPI="2"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7 3.*"
+RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Commandline tool for popular vector formats convertion"
HOMEPAGE="http://sk1project.org/modules.php?name=Products&product=uniconvertor"
@@ -19,21 +19,16 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2"
IUSE=""
-DEPEND="
- dev-python/imaging
- dev-python/reportlab
- >=media-libs/sk1libs-0.9.1"
-
-S=${WORKDIR}/${P}
+DEPEND=">=media-libs/sk1libs-0.9.1"
+RDEPEND="${DEPEND}
+ app-text/ghostscript-gpl"
src_prepare() {
sed -i \
-e "s/'GNU_GPL_v2', 'GNU_LGPL_v2', 'COPYRIGHTS',//" \
setup.py || die
- distutils_src_prepare
-}
+ epatch "${FILESDIR}/uniconvertor-1.1.5_export_raster.py_fix_import.patch"
-src_install() {
- distutils_src_install
+ distutils_src_prepare
}