summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-03 20:15:02 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-03 20:15:02 +0000
commit994e53840423504a8e6cef40756bd0c058ced520 (patch)
treed43b0c7b7e334dc5c042b7d361bfb8a534b151f2 /media-gfx
parentDisable ghci relinking hack on prefix. Found out by Wilfred Hughes on RHEL5 w... (diff)
downloadgentoo-2-994e53840423504a8e6cef40756bd0c058ced520.tar.gz
gentoo-2-994e53840423504a8e6cef40756bd0c058ced520.tar.bz2
gentoo-2-994e53840423504a8e6cef40756bd0c058ced520.zip
[QA] Revision bump. EAPI 5. src_unpack --> src_prepare. Removed extra die's. Updated HOMEPAGE; fixes bug #427696, reported by Arvydas Sidorenko. Support user's CC and LDFLAGS; fixes bug #332717, reported by Diego. Merged these changes with the contribution by Michael Mair-Keimberger (iamnr3).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/xli/ChangeLog12
-rw-r--r--media-gfx/xli/xli-1.17.0-r5.ebuild76
2 files changed, 86 insertions, 2 deletions
diff --git a/media-gfx/xli/ChangeLog b/media-gfx/xli/ChangeLog
index 2f5ddc5879f5..61e46acd5ae2 100644
--- a/media-gfx/xli/ChangeLog
+++ b/media-gfx/xli/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/xli
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xli/ChangeLog,v 1.57 2012/12/04 08:27:25 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xli/ChangeLog,v 1.58 2014/04/03 20:15:02 tomwij Exp $
+
+*xli-1.17.0-r5 (03 Apr 2014)
+
+ 03 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +xli-1.17.0-r5.ebuild:
+ [QA] Revision bump. EAPI 5. src_unpack --> src_prepare. Removed extra die's.
+ Updated HOMEPAGE; fixes bug #427696, reported by Arvydas Sidorenko. Support
+ user's CC and LDFLAGS; fixes bug #332717, reported by Diego. Merged these
+ changes with the contribution by Michael Mair-Keimberger (iamnr3).
04 Dec 2012; Tim Harder <radhermit@gentoo.org> xli-1.17.0-r4.ebuild:
Fix LICENSE (bug #445860 by ulm).
diff --git a/media-gfx/xli/xli-1.17.0-r5.ebuild b/media-gfx/xli/xli-1.17.0-r5.ebuild
new file mode 100644
index 000000000000..666f7e94e58e
--- /dev/null
+++ b/media-gfx/xli/xli-1.17.0-r5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xli/xli-1.17.0-r5.ebuild,v 1.1 2014/04/03 20:15:02 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+SNAPSHOT="2005-02-27"
+DESCRIPTION="X Load Image: view images or load them to root window"
+HOMEPAGE="ftp://ftp.ibiblio.org/pub/Linux/apps/graphics/viewers/X/xli-1.16.README"
+SRC_URI="http://pantransit.reptiles.org/prog/xli/xli-${SNAPSHOT}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="app-arch/bzip2
+ >=media-libs/libpng-1.0.5
+ >=sys-libs/zlib-1.1.4
+ virtual/jpeg:0
+ x11-libs/libXext"
+
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-proto/xextproto
+ x11-misc/imake
+ !media-gfx/xloadimage"
+
+S=${WORKDIR}/${PN}-${SNAPSHOT}
+
+src_prepare() {
+ # avoid conflicts on systems that have zopen in system headers
+ sed -i -e "s:zopen:xli_zopen:g" *
+
+ sed -i Imakefile \
+ -e '/^DEFINES =/s/$/ -DHAVE_GUNZIP -DHAVE_BUNZIP2 /' \
+ -e '/CCOPTIONS =/s/=.*/=/'
+
+ # This is a hack to avoid a parse error on /usr/include/string.h
+ # when _BSD_SOURCE is defined. This may be a bug in that header.
+ sed -i png.c \
+ -e '/^#include "xli.h"/i#undef _BSD_SOURCE'
+
+ # This hack will allow xli to compile using gcc-3.3
+ sed -i rlelib.c \
+ -e 's/#include <varargs.h>//'
+
+ # fix potential security issues.
+ EPATCH_OPTS="-F3 -l" epatch "${FILESDIR}"/xli-security-gentoo.diff
+
+ # Fix scale per bug 282979
+ epatch "${FILESDIR}"/${P}-fix-scale-zoom.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
+}
+
+src_compile() {
+ xmkmf || die
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xli xlito
+
+ dosym xli /usr/bin/xsetbg
+ dosym xli /usr/bin/xview
+
+ dodoc README README.xloadimage ABOUTGAMMA TODO chkgamma.jpg
+ newman xli.man xli.1
+ newman xliguide.man xliguide.1
+ newman xlito.man xlito.1
+
+ insinto /etc/X11/app-defaults
+ newins "${FILESDIR}"/Xli.ad Xli
+ fperms a+r /etc/X11/app-defaults/Xli
+}